Using Auth2.0 authentication for Informatica Cloud

Options

Hi All,

I am trying set up auth2.0 authentication inside Informatica Cloud for my Anaplan V2 Connector. Just wanted some feedback from any users who has already tested this successfully. As per Anapedia documentation it mentions we have to input call back URL's in Allowed Callback URL's page while creating a client in Anaplan.

Is this a required field and if yes what URL's do I have to specify for testing it with Informatica? Also what grant type should I use? It mentions Device Grant is disabled for SSO enabled workspaces so will Authorization Code Grant work in this case?

Thanks in Advance

Answers

  • pyrypeura
    Options

    Hi,

    You will need to have SSO exception user for this use case to utilise Device Grant. The callback url is required but not used for Device grant so you can input for example https://anaplan.com/ there to get past it.

  • Retroflame
    Options

    Hi @pyrypeura , does only Device Grant work for Anaplan connector? We dont have SSO enabled in our workspace, I gave https://anaplan.com as the call back URL. But I am getting the error as

    The AUTH URLs I put in the connector settings in Informatica are as below -

  • pyrypeura
    Options

    The Informatica Connector works only with device Grant. Detailed instructions on what you need to input in Informatica you can find on the link below. Could you sent screenshot on what you are inputing on the client setup?

    https://anaplanenablement.s3.amazonaws.com/Community/Anapedia/Anaplan-Connector-Informatica-V.4.0.pdf

  • Retroflame
    Options

    Hi @pyrypeura ,

    At Anaplan side its as follows -

    Informatica side -

    I tested it now after changing the run time environment, and the test directly shows successful. It does not show as mentioned in the Anaplan Connector documentation below. In API Base URL i tried both https://api.anaplan.com and https://api.r2p2.anaplan.com

  • pyrypeura
    Options

    Does the connection work if you try to do an integration run?

  • Retroflame
    Options

    @pyrypeura No the connection doesn't work, I tried to do an integration run, when I select the connection it shows unexpected error occurred. So it doesn't let me select any actions or objects, that option is blurred out.

  • pyrypeura
    Options

    Could you try deleting the connection and create new one? It might be that the oauth settings got mixed up while the oauth client setup was different.

  • Retroflame
    Options

    @pyrypeura Sure, could you please let me know which is the correct API base URL that I have to give in the Informatica connection settings page? https://api.anaplan.com or https://api.r2p2.anaplan.com

    For Auth URL I am using https://us1a.app.anaplan.com

    Thanks

  • pyrypeura
    Options

    Correct API Base url is https://api.anaplan.com .

  • Retroflame
    Options

    I deleted the connection as well as the client in Anaplan, started from scratch again and tested. It shows connection successful directly instead of how its mentioned in the Connector document.

  • pyrypeura
    edited May 23
    Options

    -

  • Retroflame
    Options

    Apologies if my earlier comment was confusing.

    Its giving the same error as before, it shows connection successful but same issue as before. I am not getting the URL that I have to copy paste into an incognito browser for the authentication to work. Instead it directly shows connection successful. Integration doesn't work either even though the steps have been followed correctly as per Anapedia and the IICS docs.

  • pyrypeura
    Options

    Hi, With this problem I'd suggest to contact Anaplan Support/Informatica support. As it's not functioning as it should be there's not much more guidance we can give you.