model to model import : Failed to locate model

Options

Hello Anaplanners,

 

I am working on a deployed model and i am getting this error when i tried to model to model import data :

 

'Failed to locate model '

 Can anybody help me on this. I am attaching the snip below

 

FYI : I am having full access and admin access to both the models.

THANK YOU 🙂

Best Answer

  • pyrypeura
    Answer ✓
    Options

    Hi,

    Could you check how your model mapping looks on source model tab?

Answers

  • @AmalmMahmoudi - Make sure you have the access of the source model which is Data hub in your case. If you have access of it, then make sure the source model mapping is defined correctly in the Source Model Tab.

  • @pyrypeura thank you for your attention , yes i checked the source model and it works on it

  • @PulkitChawla thank you for your attention ,

    yes i checked the model source and i refreshed it but the action still don't work.

    I am having full access and admin access to both the models.

  • pyrypeura
    Options

    Are the models in same workspace?

  • @pyrypeura NO they are not

  • pyrypeura
    Options

    Do the workspace have same SSO setup?

  • @AmalmMahmoudi - Are you able to edit the import action?

  • @pyrypeura i am not sure but i think yes it has some SSO setup

  • @PulkitChawla the model is delopyed and i tried to edit the import action in the model source then i passed a revision tag but still don't work

  • pyrypeura
    Options

    If one workspace has SSO enabled and one doesn't it's not possible to do model to model import between these workspaces. Would be worth to check if you have SSO enabled in either of the workspaces but on in the other one.

  • @pyrypeura i cheked now , i have full access , workspace administrator and SSO for both of models

  • pyrypeura
    Options

    source model you need to edit it in the deployed model. That mapping is not structural data so you can edit it in the target model. If that doesn't help please contact Anaplan support to investigate why connection doesn't work.

  • @pyrypeura ok thank for your help

  • @AmalmMahmoudi - Not sure why you were not able to edit the action given that it is a model to model import(data Hub to Spoc) action and not via file.

  • @PulkitChawla when the model is deployed i can not edit an import action

  • @AmalmMahmoudi - What I mean to say is just see the mapping and not updating the mapping as updating it anyways not possible until and unless the action is marked as production enabled :)

  • @PulkitChawla & @pyrypeura

    Thank you for helping the problem is solved

  • @AmalmMahmoudi would love to hear what the issue was and how was it solved.?

  • @Faisalhisham i am working on a deployed model so i need to import data from a source model,

    then when i tried to run to import action i get this error message : 'Failed to locate model '.

    So i changed the model source in " Source model" then it works.

    Do you have the same issue?