Getting an error for a user who is not a workspace adm


A process updates a numbered list from a saved view

(Module.Saved view) -> (Updates List name, parent, code and few properties)


When workspace admins run this process, it completes successfully with errors only for duplicates


When a user is not an admin runs the process however, the following errors appear:

  • You are not authorised to update this entity
  • You are not authorised to insert an item without a parent

Please note that the numbered list being updated does not have selective access enabled

Also the access rights of the user with admin access and the user without admin access, for other lists with selective access enabled, are exactly the same


Would appreciate help with this




Best Answers

  • nathan_rudman


    Have you checked the user's right tomodify the list itself ? The list you are updating must be clicked In Users -> Roles -> Lists

  • anirudh
    Answer ✓

    Hi Nathan,


    Sorry, accidentally marked your answer as the solution!


    Here's the reason for the error:

    The numbered list being updated has a parent called Country. The process updating this list had the parent field unmapped.

    The reason it was working for admins is that admins are allowed to insert items into the list without a parent. 

    A non-admin user does not have these rights and hence when a user tries to run this process, the parent field being unmapped, it will not run and Anaplan throws an access related error.


    Thank you for the help


  • So what is the solution for this if we want a non-admin to be able to create a new list item with a parent via a process(and action)?


    My use case is this:

    I have a input module where users input Cost Centre, Job profile and Grade, and I then want them to be able to import this to a list (with Cost Centre as the parent).


  • @CommunityMember115752 


    Simply give the Role the users are assigned to Write access to the list which can be found in Users-> Roles Lists.


  • Thanks Rob, but I'd already tried that, but am getting an error from the user: "You are not authorised to insert an item without a parent".

  • I should add that the parent field is being mapped.

  • @CommunityMember115752 


    Are they running an action to insert these members?  If so, you will need to have the parent mapped in the action.  If you are using the Create Action, which can only be used on a numbered list, then the user will have to have the "scope" on the parent when they click the Insert new member.



  • the parent is mapped, but they are running an import action (importing multiple items, not just one at a time).  The import action is one step in a process.

  • @CommunityMember115752 


    Can you show a picture of the mapping?  Is the parent list a numbered list?  If so, you will need to use the code of the parent for your mapping.



  • Thanks Rob.

    That's solved it.  I was using the list item itself, rather than the CODE.

    We have to use CODE for a numbered list.