Dashboard - settings of initial page


Hi Everyone,


When we set up our dashboard, we use "initial page" to put the default landing selector.

It worked in the past.


But recently we noticed that "initial page" can not be changed any more, after you publish the first time the dashboard. The yellow highlighted section is fixed to the "..." and can not be selected any more.


Initial Page.JPG

We tried to re-publish the same content to a brand new dashboard and still got the same result, not be able to change the "intial page".


But this did not happen on all selectors, some lists / line items work in one dashboard, but don't work in other dashbaord, all random.

Is it a bug in the recent released version of Anaplan in Dashboard?

It never happened in the past to us.

Does anyone have the same experience? How we can solve it?


Many thanks in advance!






  • Hi Yiping,


    I'm have never experienced this.  


    Line Items as page selectors should have the same options as lists (i.e. Initial Page can be the default, or a specific line item selected)...


    I'm curious to see the module as a whole, can you share some more details?



  • yqian

    Hi Paul,


    Thanks for looking into that.


    Yes, we did not have any experience like that in the past. We were able to adjust the intial page regardless if it is a list or a line items.


    I am not sure if it came with the new release of the dashboard feature and this does not work all time any more. Sometimes we are able to switch the initial page, sometimes are are not.



    1) we can switch FY18 to FY19 in the intial page in Dashboard 1, but we can not switch FY18 to FY19 in the initial page in Dashboard 2, all locked.

    2) we can not switch product A in Dashboard 1, but we can switch product B in Dashboard 2 in intial page settings.


    It seems a bug that never happend to us before.






  • Hi Yiping

    Were you ever able to find a resolution to this? I was just changing one of the Initial Views on one of my dashboards and have this same issue. It is odd because I can click the drop down menu to select my intial page, but after I click on it, nothing happens. The list does not disappear.  This was the first time I entounered it. I cleared cache in Chrome and was able to replicate it in Firefox and IE.Not sure if this is a bug on Anaplan's side?


    Dashabord error.png


    I re-published the module to my dashboard and was able to select the default view.  


    Hopefully there will be a resolution for this.



  • Spoke too soon :), re-publishing did not work. As soon as I saved the dashboard, the same thing happened. 


    I chatted with Support and it is a bug that is being worked on. It happens when there are more than 3 initial page selectors and they are set to anything but 'Default'. The second initial page selectors becomes unusable.

  • yqian

    Thanks Brendan. I think it is a bug as well. We also submitted ticket to Anaplan Support.



  • yqian

    The temp solution we received from Anaplan Support is:


    1) edit Dashboard

    2) set all "Initial Page" to "Default"



    3) exit "Edit" and go back into "Edit" mode

    4) Re-set to the initial page that we want to see


    Thanks everyone!





  • Just to follow up and close the loop on this, I was notified this morning by Support that this bug was fixed.