How to apply filter in a line item (subsidiary view)?


I am trying to apply a filter in a line item, which is used list as format and is subsidiary view.




  • Hello,


    Applying a filter to a line item (formatted to a list) is as simple as clicking the Filter icon and creating the filter.  Sometimes its easier to select the line item and then click the filter, because that usually creates the basic filter for you (and then all you have to do is select the values you want to filter to in the filter dialogue box).


    If your question is a little more involved, lets say you want to be able to filter to a line item using a selector in a dashboard... well, that's a horse of a different color!  If that's the case, you probably want to use User Level Filters.  Take a look at this post for an example:



  • chp127

    Hi Paul,


    Thank you for your response.


    I am facing issue with filtering line item ( line item used list as format and is subsidiary view ) publised in dashboard.Its showing “Unsupported Operation 'Filter' ”.


    That is limitation or there is any way to apply filter on line item(used list as format and is subsidiary view) publised in dashboard.

  • I can apply a filter in a dashboard using a line item that is a subsidiary view.


    Can you pls share images of the report you want to filter in the dashboard, as well as a blueprint view so I can also see the subsidiary view line item?

  • chp127

    Hi Paul,


    Kindly find attached dashboard line item and blueprint, where I tried to filter but using the filter I got an error that "Unsupported operation filter". and when tried filter list option, pop up was coming but no value available in the drop-down.Line item used list in format and is subsidiary view.

  • Hi,


    The feature is working on my end using a subsidiary view line item formatted to a list.  I do see that you have some values populated (and some blank)... the pick-list will only include list items that are being used in the subsidiary view line item.  


    There are times when the nature of the pivot prevents filtering. 


    If you can provide a full blueprint view of the module (really just the main columns), as well as a fuller picture of the dashboard, we can take a close look. 

  • Hi @chp127,

    The replies from @PaulRitner are true. We would like to know what you are trying to achieve here.


    The ways that you can apply filter are as follows in the snapshot that I have provided you.


    1) You have created a subsidiary view

    2) Here you have to go inside the view and then publish it to the dashboard.

    3) In the dashboard, you can apply the filter as you like.


    4) The unsupported filter operation is due to applying it straight on top of the subsidiary line item. That is the case when it shows 'Unsupported filter operation' 


    Now, what I did was try to recreate the error that you got. There are other ways in which you can go about and achieve what you want to achieve. This is one of the ways you can do it. Hope this helps. Let us know whether it served your purpose.