Compare and Sync Error

Hi Team,


I have performed below steps in Anaplan for one of my code change. I have one test model and production model. Both were compatibile and in Deployed mode. To move some changes to prod, I have followed the below activity.


1. I have used "copy and archive" option to archive production model and deleted the same.

2. Then we un archived the previously archived model which has the same structure.

3. While doing a compare and sync with un archived model and test model, its showing "We couldn't find any source model to compare with the target model". 


Could anyone please help me to understand what went wrong here. 







  • Hi @Devika

    I see that you are trying to transfer the changes from TEST model to PROD model. However, you copied the PROD model and archived and now you want to COMPARE AND SYNC with the existing PROD model? Hope my understanding of the question is right.


    Now, what I would like to know is have you created a REVISION TAG after making the changes in TEST MODEL? If not create revision tag now and then try COMPARE and SYNC. It should definitely work. Also, please read about revision tag in ANAPEDIA.


    Click here for revision tag article

    Hope this solves your issue.

  • Hi Aditya,


    Thanks for your support. Yes, you're correct. I have latest revision tag in Test model. But when we open the Compare and Sync button, Anaplan is throwing me an error related to source model couldn't find. In fact, I have tried this scenario in our Dev workspace before touching the production workspace. This works for me there. 


    Just curious to understand, is this something related for the deletion of prod model.




  • Hi @Devika,

    It works and Dev space and not in Prod workspace. Strange! However, you also have an option to COMPARE AND SYNC with a different workspace. Try this method and let me know if it works. Also, whatever steps you just mentioned over here, worked for me. I followed the same steps as you have instructed me and it works. Give this method and hope this helps.



  • Hi Adithya,


    We had tried editing the source model mapping for connecting to DEV-Test workspace. But the issue was persisted. 


    Further analysis, we have noticed that the person who was doing the compare and sync doesn't have workspace admin access in Test model.I had provided him the access and he is now able to sync Test Model and Prod Model. 


    The error message made us all these confusion about the compatibility with Test model.


    Thanks a lot for your prompt response. Your answer gives us the confirmation on "Copy and Archive" process as well.




  • Hi @Devika,

    Haha, sometimes the most complex of issues have the simplest of solutions. Thank you for your reply as I too got to learn something from it.