Updating Organization List - best practice




I have a module that works out accruals & prepayments by contracts and when each contract gets added it is mapped to an organization parent. The issue I have is that the organization list constantly changes each year and therefore needs to be remapped. I know if i delete and import a new organization list, i will lose the data so just wanted to know the best way to update a changing organization structure. To give an e.g. I have a contact CA123456, it was created as AB-123 CA123456 (AB-123 being the business unit it belongs to) but now the contract has moved business units as part of a restructure and is now CD-123 business unit. I am able to change the parent to point from AB-123 to CD-123 but I am not able to rename the child to say CD-123 CA123456. So i am wondering, because the structure changes every year, is there a way to mass upload an organization hierarchy without losing the data?


Hope this makes sense and if it's better to schedule a call to show someone, that would be great. 





  • subodhp

    So i understand that the reason why that is happening is because Annaplan connect is importing the data source as private files and what i need is default files. I see no option of changing that either at my end or at the users end who is importing the data through a batch file. 

    What we also tried was to create an import data source from the UI which was tab delimited and i set the view as default view - Everyone and tried to get the data loaded into this data source. However as soon as the user loads data into the data source using the batch file the permissions change to private files.


    Please let me know if there is any way out so that i can view the data without anyone else having to intervene in between.

  • Sheethal

    From your question I understand that you want to see the data imported from SQL table in Anaplan & you are trying to do this through "Import Data Sources". I assume you want to see the data in Anaplan as a review step, before it is pushed to destination module.


    My suggestion would be, instead of trying to see the data through "Import Data Sources", you can import the data to a temporary module and review the data there. And after review you can push the data from temporary module to destination module.

  • We hit this problem too.  Seems the way to fix this is through the Action.

    See this info as it helped us figure out what to do to fix the issue:  https://help.anaplan.com/anapedia/Content/Import_and_Export/Import_Data_into_Models/Overview_Private_Default_Files.htm?_ga=2.163537212.1486881565.1538087808-649252236.1500578556


    Our solution was to choose either Admin Only or Everyone (depending on the data), and we no longer received the error.