Anaplan Connect to MS Access


Hi All,


I am trying to use Anaplan Connect to import data from MS Access table to Anaplan list.  The table has only one column containing list values.  I have created Anaplan import action based on text file with similar structure i.e. one column file.


I create file as below

jdbc.connect.url= "Jdbc:Odbc:Driver={Microsoft Access Driver(*.mdb); DBQ=C:\Data\Anaplan\301 Anaplan Connect\Database1.mdb};"
jdbc.query=” SELECT * FROM Table1”


Database1.mdb and Table1 are my access database and table name


I use this Operation in Anaplan bat file, where I put the name of the import action after -file, and location of the after -jdbcproperties.

set Operation= -file "Prospects from Prospects.txt" -jdbcproperties "C:\Data\Anaplan\301 Anaplan Connect\anaplan-connect-1-3-3-5\"

I downloaded MS Access JDBC driver for MS Access and copy the jar file and other extracted folder to Anaplan Connect folder.  However, when I run the bat file, it gives message that it cannot find lib directory


Do I miss anything or set incorrect parameter in the .bat and configuration?





  • Andre -


    Do you still need assistance with this?


    If this is still an issue you may want to open a ticket with Anaplan Support on this to review the JDBC properties file syntax requirements.


    I'm not an SME here, but based on a quick review of what you've provided, I'd test the notation of the 'jdbc.connect.url=' property. I'm not sure that what you have will work as you intend it to. You may want to start with the syntax from the example in the AC guide. Do you have a copy of that?





  • Hi Ernie,


    Thanks for the response. 


    My initial intention was to test Anaplan Connect with database.  So, I used Access as I thought it was the easier one to test on my local.  As there was problem with Access, I decided to test it using MySQL.  The connection worked as I expected but I included the JDBC connection information in the Anaplan batch file instead of using a separate JDBC properties file.  It still did not work with separate properties file though.


    Here is the working set Operation in my batch file.


    set Operation=-file "Anaplan_Demo_Sql" -jdbcurl "jdbc:mysql://localhost:3306" -jdbcuser "username:password" -jdbcquery "select distinct name from where name <> 'San Miguel'" -import "SQL from Anaplan_Demo_Sql" -execute -output  "C:\Data\Anaplan\301 Anaplan Connect\anaplan-connect-1-3-3-5\error.txt"