Cant edit saved Import


A month ago I created an Import from a CSV file to a numbered list, included the import in a process action and published the action to a dashboard. When a user clicks on the button they are asked to browse to a source CSV file and click OK. If the CSV file is in the expected format the Import works. However if something is wrong with the format the import fails and there is no detail given to help understand why. If as an admin I try and run or edit the import action directly (from the Anaplan Actions Import tab) I am told "The uploaded file is no longer available; please upload the file again", and this is even if I have just successfully uploaded a file via the dashboard. I therefore have no way of resolving the issue when the Import fails. The only option seems to be to redo the import from scratch.


Having delved a bit in this forum I see that I can save an import source file as a default file which I am guessing will mean that once I have done that I should be able to edit the import whenever required and identify what was expected and hence why a source file caused a failure. But as this is one of over 100 imports that have been created and saved the thought of having to redo every import and republish them is a nightmare.


Has anyone found a way to edit a saved import without having first saved a default file for it? Why can I run the import from the dashboard but not directly and why having done so do I still get the "The uploaded file is no longer available; please upload the file again" message when I try to edit the import. (I hoped this would have allowed me to make the default file setting without the need to rebuild each import from scratch)


Finally has anyone found a different more robust way of allowing a user to import a CSV?

Best Answers

  • nathan_rudman



    If you look in the "Actions" menu of Anaplan, you'll get three tabs: actions, imports and import data sources.


    Every import is based on an "import data source".

    Look at your import take the source label and search for it in the "import data sources". You should find it, edit it. if it tells you file no longer exists (which it will), it means you need to reupload the file.

    That is possible, if you just do "new source" and upload a file named the same way as the original one.

    You should then be able to edit your existing import.


    Personally, I just usually re-do them when the mapping needs to be changed.





  • Peter40
    Answer ✓

    Thanks Nathan, I did not realise that importing a CSV file with the same name would cause the data source to be replaced. Doing that does indeed allow me as an Administrator to then edit the original import definition and fix the issue. It also allows me to make the file I have just imported a default file for Admin only so that it will always be possible to edit the import action in future. This is a good step forward but what still concerned me was that the normal user without admin rights is unable to resolve the issue themselves so must always call support. The usual cause of the failure is that they have used a different name for one or more of the column headers in their CSV file. Therefore what I have now done is add a tool tip to the Process Action button that tells the user the column header names that must be used.


  • Humm, yes for system integration, format shouldn't change...

    Maybe you can do several imports to accomodate for several formats ?