Backup & Restore


Hi everyone, I need your support regarding the restore function. Indeed, I have a model with 2Go which contains the data of 2014 and 2015. To reduce the occupied disk space I deleted the data of 2014. The space disk remains the same (2 Go). So I copied and archived the model (with data of 2015 only) and restored it, however the space disk remains the same (2 Go) again. Could you explain me why I cannot reduce the model space disk in Anaplan ? Is there another solution ? Thank you in advance for your help.



  • Hi Amine,
    The size of the model is determined by the number of cells, regardless whether they are empty. Check in Time in Model Settings to see whether you still have 'Number of Past Years' and 'Number of Future Years both set to 1, which would mean that both years are still in the model.
  • Hey Amine,  We are in a similar problem right now in our model. were you able to get the solution to the problem Amine? Appreciate your response since we are in  critical stage in our model. 
  • Hi Amy,
    Thank you for your feedback.
    Before making the backup of the model, I set "the number of past years" to 1 (in Model Settings > Time) and "the number of future years" is set to 0. So the model contains the years 2015 and 2016. The data of 2014 were deleted, but the empty cells are still present in the model. 
    Is ther any way to delete the empty cells ?
  • Hi AMO,

    Unfortunately the solution is not yet found. I don't know how we can delete the empty cells...
    If you find a solution from your side please keep me informed.
    Thank you.
  • Hi Amine,
    Your old model had 2 years in it (2014 and 2015) and was 2GB big. Your new model has also 2 years in it (2015 and 2016) and is also 2GB big. Everything seems normal. Can you confirm?
  • Hi Jérémie,

    The data of 2016 are not yet imported in the new model. So basically the new model should have less than 2GB (data of 2015 only). 
    We can explain that by the delete of data and not cells. In this case, how can I delete the empty cells ? 
    Thank you for your help.
  • Hi Amine,
    All empty cells are counted in the model size. That's why Anaplan calculates so fast, because all cells are already in memory.
    If you really want to delete 2016 cells, you need to change your time settings and keep just 1 year in the model.
  • Hi Jérémie,

    Thank you for this explanation. 
    So, regardless of the data size (text, number,...), the real size in Anaplan is calculated by the number of cells already allocated in memory. In this case I can keep tha data of 2015 and 2016. Am I wrong ?
  • Correct. You can see the data size (number of cells) for each module in the module tab.