Anaplan error 404 when importing to Anaplan


I have error when importing data to Anaplan using new CA certificate and version 1.4.1.


This command working in Anaplan connect

java -d64 -Xmx48m -Dhttps.proxyHost=XXX -Dhttps.proxyPort=8080 -jar "XXX\anaplan-connect-1-3-3-3.jar" -c "XXX\xxx.cer" -workspace "XXX" -model "XXX" -file "XXX.txt" -put "XXX.txt"


This command not working in Anaplan connect 1.4.1.
java -d64 -Xmx48m -Dhttps.proxyHost=XXX -Dhttps.proxyPort=8080 -classpath "XXX\anaplan-connect-1.4.1-jar-with-dependencies.jar;XXX\Anaplan Connect v1.4.1\lib\" com.anaplan.client.Program -keystore "XXX\xxx.jks" -keystorepass "XXX" -keystorealias "XXX" -service "" -auth "" -workspace "XXX" -model "XXX" -chunksize 1 -file "XXX.txt" -put "XXX.txt"


Error message:

-- Initializing Service...
-- Authenticating via Certificate...
ERROR c.a.client.Program
-- Server files not found: Server-Files not found for Model-ID=XXX (Feign: status 404 reading AnaplanAPI#getServerFiles
(String,String,int); content:
"status": {
"code": 404,
"message": "Resource not found"


Do you have any idea what is incorrect?



Best Answer

  • jirkajiri
    Answer ✓

    Problem solved. Model and workspace have to be IDs, not string as it was in previous version.


  • Have you tried running the 1.4.1 command using basic authentication?


    Did you upload the Public Key to Anaplan?



  • Using basic authentication:

    version is working:

    java -d64 -Xmx48m -Dhttps.proxyHost=XXX -Dhttps.proxyPort=8080 -jar "XXX\anaplan-connect-1-3-3-3.jar" -user "XXX:xxx" -workspace "XXX" -model "XXX" -file "XXX" -put "XXX"


    version 1.4.1 the same error:

    java -d64 -Xmx48m -Dhttps.proxyHost=XXX -Dhttps.proxyPort=8080 -classpath "XXX\anaplan-connect-1.4.1-jar-with-dependencies.jar;XXX\lib\" com.anaplan.client.Program -service "" -auth "" -user "XXX:xxx" -workspace "XXX" -model "XXX" -file "XXX" -put "XXX"


    --   Initializing Service...
    --   Authenticating viaBasic...
    --   Server files not found: Server-Files not found for Model-ID=XXX (Feign: status 404 reading AnaplanAPI#getServerFiles(String,String,int); content:
      "status": {
        "code": 404,
        "message": "Resource not found"


    Did you upload the Public Key to Anaplan?

    Yes to Anaplan administration app.




  • Hi @jirkajiri 


    There was another change in our back end that may be causing this. If you're attempting to access the workspace of another tenant via API, even if you have model access, it will return a 404 error due to tenant isolation policy.


    For example, as an Anaplan Employee, my tenant is Anaplan Employee. If I tried to use my login to test Anaplan Connect in a customer's workspace, even though I have access to the model, I would face this error. Does this apply in your case? If not, there's still a possibility that your email isn't associated with the correct tenant, you'll be placed in the tenant of the workspace where your account was created. For example, if your account was created when someone added you to an Anaplan Global Enablement workspace, that would be your tenant. If this is the case, you can email our Support team to correct the error. If you're working with a partner, trying to test AC for a customer, have them create an integration account (this is best practice anyway) and share the credentials with you for testing purposes.



  • I ran into a similar issue with Anaplan Connect when I tried to export from a new model using script from another model's working export. I got the error shown below because the Anaplan service user that was used to execute the script didn't have rights to the model. When I gave that user Full Access in the Model Role under Users, it fixed the problem.




    |--   Exports not found: Exports not found for Model-ID=XXXXXXXXXXXXXXXXXX (Feign: status 404 reading AnaplanAPI#getExports(String,String,int); content:


      "status" : {

        "code" : 404,

        "message" : "Not Found"