Create Action missing context problem


I have an action to create items in a numbered list. The parent list has only one item "ALL". I am having an issue on my dashbard where I get an error as below.

2019-05-03 11_44_29-Anaplan - Budget Transfer _ Consolidation.png


It seems like the user is missing the parent context and it is not selecting the first item in the parent hierarchy as described in Anapedia... 


If a user clicks the button immediately, before a parent context is established, the first item in the parent hierarchy is used.


2019-05-03 11_50_13-Anaplan - Budget Transfer _ Consolidation.png

I have tried adding the parent list as a selector but this has not resolved the problem. Is there anything I can do to force the parent context to make the button work?







  • dkolka



    Please check security to make sure users are appropriately assigned.


  • Hi Thanks for your response, the relevant user role has access to the action and the parent and child lists. I can also replicate this issue with Full Access role. 


    Sometimes clicking on the module and then on the create button works, but not everytime. 

  • dkolka



    I was able to recreate the error message although I had to interpret settings.  Some may be applicable to your environment/situation.  Short story is to check that users have correct Selective Access for the Lists flagged as such and next check correct Access to Version.  If its set to NONE then you could get this error.  I suspect that the "sometimes" it works phenomena is related to Versions changes from a read/write list item to one without access.


    Steps to Recreate:

    1. First even with Full Access IF Selective Access is flagged for a list a user or team needs to be set to Read or Write Access.
    2. In my test I set the Parent level list to Selective Access and set my self as Read Only.  This Profile is inherited by to the child list.
    3. Next I set User Security > Role > Version for Actuals to None
    4. Then ensured that in my Module Versions was set to All
    5. Lastly I tried to add a new list item.  This resulted in warning message.2019-05-03_14-31-26.jpg2019-05-03_14-38-45.jpg2019-05-03_14-38-19.jpg

    If this still doesn't resolve it please send along exact steps to recreate along with scrn shots of User secruity, List and module settings.


    Hopefully this solves it.