Error when changing list dimension to subset

HI,

 

I have a list as dimension in one of my modules, and I am trying to change that dimension to a subset of the same list. However, when I try to do that, I get the following error message;

"To serve as an access driver, a Top Level Item must be present on any line item dimensions that don’t match those of the target module or line item(s)."

I have never seen this message before, but have tried a few different things. First, I do have one Access driver in the module I am trying to change dimension of, but even when I remove that driver, I get the same message.
Also, I have checked all modules that are connected to the model with the issue, and none of them have an access driver.
 
It is vital that I get this to work asap, so any help is highly appreciated! Thanks a lot!
Tagged:

Best Answer

  • Hi,

    It worked to "rebuild" the module with the correct dimensions from the beginning.

    Thanks a lot!

Comments

  • @fredrickstaube

    try this

    download ur module to excel in blueprint mode this is just to save your formulas

    then remove all formulas and access drivers

    change dimension

    put ur formulas back

  • Hi @fredrickstraube 

     

    The error suggests that your list does not have top level (a top level that all the items in the list roll up to).

    So you could try adding in a top level to your list and see if this resolves the issue.

     

    Also it could be that one of the line items in your module may reference a specific list item not a whole list dimension which is preventing you from applying the subset? 

     

    Alternatively you could 'rebuild the module' by copying all the formulae from the module and then delete them and remove the access driver and then change the dimension to the subset and copy back the formula and driver access. If this does not work it will highlight which calculations will need to be changed.

     

    I hope this helps,

     

    Thanks,

     

    Usman

  • Hi,

    I tried this, but got the same error... I traced the error back to the access driver I have in my module, and it is almost like the module doesn't realize that I have removed it before changing dimension.

    I did however create a new module that looks like the old one, but with the correct dimensions, and then added the same formulas. And when I added the access driver again, it worked. So issue solved. 

    Thanks a lot!

  • Dear All

     

    I have the same problem when trying to remove the top level of two members list

     

    I'm trying this to gain space,

     

    what whould be the solution ?

     

    Thank you

  • @Ala_CHKIR 

     

    If you have a line item that is summing the data in the list, you will need to have the top level.

     

    Hope this helps,

     

    Rob

  • Hi @Ala_CHKIR

     

    When you want to make a structural change the best thing to do is:

    1. Copy the module

    2. Copy save and then remove the formulas

    3. Make the structural change

    4. Paste back the formulae 

    5. See if this causes any issues and then address the formula changes.

     

    I hope this helps!

     

     

  • Hi @fredrickstraube ,

     

    SOLUTION:

    To solve it, I removed all the DCA linked to the line items from that module and then I could change the dimensions of accordingly.

     

    Hope this helps 🙂

    Thank you!

  • I Removed all the DCA to the line items of the module and you may change the dimensions.

  • I received the same error, even though I had deleted the DCA. I had previously copied the module. By removing the DCA also from the copied module, I was finally able to change the applied list.