Import Error

Dear,

 

Whilst importing a .txt file into the Datahub we encounter the error 'unmatched delimiter character at line 100968 character 17'. 

 

Tried looking in the datafile and erasing the datarow and uploading again but nonetheless we have the same problem.

 

Hope somebody can help.

Best Answer

  • DavidSmith
    Answer ✓

    @HendrikDeCuyper 

    I had this issue a while ago

    The problem I had was that there was a delimiter (in my case a comma) within the description of the fields.  What was happening was the import then parsed and it was looking for the "end" but couldn't find it so it errored

     

    Have a look at the Text delimiter settings on the import tab, or try and use a different delimiter.

    2019-07-03_15-52-15.png

    I hope this helps

    Good luck

    David

Comments

  • Hi David,

    Thanks for the fast reply.

    Put the Text Demiliter to None and it worked!

    Thanks again,
    Hendrik
  • Excellent

     

    It took me about 4 hours to find it as my file was about 10 million rows.  I worked from the bottom up, splitting the file in half each time

     

    The error was in row 100!!!

     

    David

  • Hi David & Our Anaplan Experts,

     

    @DavidSmith Thank you so much for this article - it saved me a lot of time as I went straight with searching for double quote. 

     

    My issue is that I do need to use delimiter for my nightly automated load using Anaplan Connect.  I have little control at the moment to prevent my users from entering a " or ', which will end up in our load file.  

     

    I know we probably need to solve this issue at the data source but is there anything we can do to mitigate this issue (e.g. automatic scan this records) without restricting user input?

     

    Thank you so much,

     

    Lily