Import to time based module with "ask each time" time selection



i have met the following issue. 

There are two modules:

- Target Module: Time based (Year) 

- Source Module: no time dimension


when doing import , I chose "ask each time " option for time dimension , and during import run i select that single year which is presented in the module. the import is running successfully but all ignored and nothing is being loaded.

if i add text field in source module with year name "FY19"  and map it in import settings, the data is loaded successfully.

So I do not understand why fist option is not working for me.


thank you 


  • Hi,


    I have tried your scenario, for me its working fine. 


    Source Module:

    List: Employee

    Line Item: salary


    Target Module:

    List: Employee & Time

    Line Item: salary


    I have selected "ASK each time import" option, to import data to particular year based on my year selection.


    Please check your source and target dimensions, there is some mismatch.



    Vignesh M 

  • Hi @VIGNESH.M  thank you for your reply, here are some more details:

    Source and Target modules are located in different models- this is truth (i do not think it should be the reason for the issue) , but all dimensions are mapped successfully in import settings (except for time)


    -  Source module: 

                    List: Currency, Line Item: CY Ex Rate

    - Target Module:

                    List: Source Currency (both currency lists have the same codes and mapped successfully), Line items:  Ex rate (mapped manually to Line item "CY Ex Rate") , time year.


    so when selecting time during upload : import is successfully completed and all elements ignored.



  • Hi Aleksandra,


    Tried to recreate the scenario you are working, For me its working perfectly fine. Not sure where is the problem exactly.


    Is your currency list is the number list?. if it's number list, then map code to Currency List. Include Column code in source Module.



    Vignesh M