Import error (parent item has a child item that is in a different list)


Hi all,

I'm getting the following error in one of my import:


Import into Hub_0_Product_Group Marketing L8 # list failed: Parent item has a child item that is in a different list:
You can only add a child to a parent item, if any existing children of that parent item belong to the same list.


Do you have any tip/advice to detect and fix the root cause of the issue ?

I'm struggeling on that.



Best Answer

  • ChrisAHeathcote

    Have you tried using a numbered list? 

    If so, and the error persists it would appear that you are trying to create a parallel hierarchy.


    Create a duplicate second hierarchy using the desired parents and children ( this parallel hierarchy will contain a duplicate parent and the second child )


    Create a mapping module which maps the two hierarchies using the parallel hierarchy's child list as the dimension and the primary hierarchy's parent list as a list formatted line item. Establish the relationship between parent and child and use this mapping when creating aggregation using the parallel hierarchy.


  • Does the code used in the child also exist in one of the parent lists?


  • Hi David,

    Thank you for your reply 🙂


    The parent list is a subset and I was importing items outside this subset into the child list. After having updated the source to export only items part of this subset it's working.



  • Excellent - Glad you got it sorted
  • Thanks Chris, I'll try this if I face this problem again

  • Hi Maxime,


    I am also getting the same error and i am using the sub set as a parent but didn't got what you did to solve the issue can you guide me what you did?

  • @Maxime.Schaller Thank you so much for this post! We had a similar subset parent issue and managed to resolve after reading this.

  • i am facing the same issue, but in my case this error is happening only in deployed models where as in "standard mode" dev model, it is creating list members without parents.