New UX Forms - You Cannot Create This Item


I am creating a page in the new UX to give users the ability to add new Strategic Suppliers to a Strategic Supplier List.  I used the Form Editor to create a form, but I am getting an error message that says "You cannot create this item".


I've searched Anapedia for all things related to forms, but haven't found anything that explains why I am getting this message.


Some additional detail/background: In the classic UX I have the ability to "Create" a new item in the list, and it works just fine. The list I am adding to is a numbered list, but I also created a non-numbered list to see if that was causing the issue but I got the same error message.


Does anyone know how to get Forms to function in the new UX?



  •  Hi @ebayliss


    This maybe because you're creating an item in list without selecting what the parent relationship is, this may need to be added to your form. 


    All the information on creating forms can be found in the link below:


    I hope this helps.





  • Thanks for the reply, but I did include the parent selection on the form and I still had the "you cannot create this item" message.

  • @ebayliss did the item have the same name as an already existing item? 

  • So after playing around some more, I discovered that the only was I am able to add an item is if the Parent is pre-selected in the form designer.  When I try to enable to ability of the user to select the parent I get the message you cannot add this item, and the message doesn't go away even once the user selects the parent.

    How can I give the user the ability to add an item and chose the parent for that item?




  • @ebayliss 


    I would've thought that selecting that option in the settings would allow you to that.

    When you created the form was that setting available in the creation of the form? If it was then maybe you need to re-create the form with this applied to begin with. 


    Is there any selective access applied to any user role that has access to this form? 

  • The option was available the first time I created the form, and I did have it enabled the first time I created the form.  Again, the form only worked when a parent was pre-selected in the design view...with that logic, one would need to create a separate form for every single parent available.  


    Also, there is no selective access on the user role that is adding the new list item.

  • @ebayliss 


    It is possible then this might be a bug/issue with the New UX. 

    I also agree with you that it should be possible to create a form without having a parent pre selected as otherwise this would mean many forms required for a simple input. 

    You could contact to report it as a bug and see if they are able to resolve this as it maybe currently unknown. 





  • @ebayliss 

    Could you leave feedback in the UX itself.  this is our preferred method for finding/fixing issues at the moment for New UX

    The feedback option is top right hand side of the navigation bar at the top


  • Will do!

  • I encountered a similar problem and was able to get the item to be created after I enabled the "Code" property to the form.  I did not need to enter a value for Code when trying to add the item, I just needed the Code field to be on the form.