Anaplan Connect Upload Error


Hi, This is the first time I am using Anaplan connect. While creating the script and looking at the documents, i drafted a script that allowed me to first upload, import thru an action followed by lastly a process.

I have apparently uploaded the file successfully however I am met with problems with my action that imports the file into a list.

To add on the specific error shown is: errorMessage - The uploaded file is no longer available; please upload the file again. In addition, moving to my model, if i run the action manually it now faced the same problem, which it did not just minutes ago. Further if I manually do the import by selecting the exact file, it shows me: an internal error occurred in some instances. 


From the above, I would conclude that the import had an error, however from the cmd prompt, the import seemed fine


Below is the script



@Echo off
rem For Windows OS : This example explains the usage of basic Authentication with Anaplan Connect.
rem It also loads a source text file and runs an Anaplan import into a module.
rem For details of how to configure this script visit


set AnaplanUser="...:..."
set WorkspaceId="..."
set ModelId="..."
set ServiceUrl=""
set AuthUrl=""
set FileName="123.csv"
set FilePath="C:\Users\123.csv"
set ImportName="test import"
set DumpName="Client Location for Dumping the Errored data from Import"
set Chunksize=1
set Process = "Test Anaplan Connect"
set Operation=-debug -service %ServiceUrl% -auth %AuthUrl% -workspace %WorkspaceId% -model %ModelId% -chunksize %Chunksize% -file %FileName% -put %FilePath% -import %ImportName% -execute -process %Process% -execute -output %DumpName%


rem *** End of settings - Do not edit below this line ***

setlocal enableextensions enabledelayedexpansion || exit /b 1
cd %~dp0
if not %AnaplanUser% == "" set Credentials=-user %AnaplanUser%
set Command=.\AnaplanClient.bat %Credentials% %Operation%
@Echo %Command%
cmd /c %Command%


Thank you in advance for the help. 

Best Answer


  • Hi there,


    Just looking at the response provided.


    If you are using ANAPLAN CONNECT, there is no way to reselect the file, or indeed when you set up the import after running a process in Anaplan Connect, there is no way to Set Default File to Admin?


    The example given shows a CSV, but again if you are using Anaplan Connect, the Import is already present. Is there a setting in Anaplan Connect in the script, to tell Anaplan the Default File is Admin and not private?


    Kind Regards,


  • Hey there @gavina,

    Late reply but if you refer to Anapedia, it is apparently stated that setting default files via API is not possible.

    Yours Sincerely,