Rogue data appearing after Import


I have a Module with many line items, and time using w/c and versions

I have a saved view and it looks perfect.

I have another Module with 3 line items, and time using w/c and versions.

I import data from the 1st Module to the 2nd Module from Version: Latest Estimate to Version: Forecast -1.


It imports data that does not exist..... anywhere.....


Very hard to explain but hope these images help

in this image is the source data... and there is NO OTHER DATA for this product, in this week



in this image is what is importing to the second module, and it is clearing prior to import...



How can this be, these numbers are NOT IN THE MODULE anywhere, but they appear when we import.


Any suggestions please?



Best Answer

  • nathan_rudman

    ok if you have only one version filtered in the source then it should work.


    One potential issue I see from the mapping is that you are mapping the customer using the list itself while it is a numbered list. This is known to cause issues. It is better to create a line item "customer code" that will contain the code of your list (hopefully it has one ?) and use that line item to map the list.


  • A couple of suggestions.

    Check your dimensions. Is it possible you've left a dimension unaccounted for in your target module? If so, it will sum all instances of the Isla Negra Sea Shore list item on the unaccounted dimensions. You may want to screenshot the pivot on the source and the destination so we can see it.

    Also, you say the module is clearing before you import. You may want to test that too.


  • it would be helpful if you could show the action mapping settings ?


    do these values come from another version by any case ?

  • Hi, here are the images of the import, there are other versions in the source but they are all empty.




    The view I am importing from is saved as one version... that seems to be the only possible issue, but i have no data in the other versions..



  • Hi @DeveloperCYT 


    One approach to resolve issues like this via testing is to create a saved view that has minimal dimensions, for example import to one product. Then see if in this import there is a similar issue, then when you scale up to the full list of dimensions you can evaluate what is contributing to the error. 


    It could be very likely that this issue is to do with the formatting of the time dimension which may be causing aggregation. 


    I hope this helps.





  • i have tried every time dimension mapping, and all fail to import, the only one that imports is 'match names'

    I import over 10,000 records and about 12 fail to import exactly the same and 3 add in large volumes that do not exist.


    it is a mystery


  • this is intra model right ? with standard time dimension ? if yes then very unlikely time being the issue
  • Fantastic

    I used the code in the view, and imported and voila, all present and correct

    That was a useful failure

    many thanks to all suggestions


    Solved and Happy, thanks