Publishing Graphs Using Dynamic Cell Access - Is there a Bug?

Hi Planners,

While I was working on graphs I found something weird going on while Publishing graphs using DCA. I am not sure if this is supposed to work exactly the way it is or is it a bug in the system.

I have a Module with two line items Line A & Line B across monthly timescale
I am using DCA Read Only for Jul, Aug & Sep and I am hiding numbers for Rest of the months - See attached document for snips
When I publish the Line Chart graphs for these two lines I found that Jul, Aug & Sep Values of Line B are being shown in Jan, Feb & Mar Timescale - See attached document for snips

I think DCA looks for first non Zero Value and places it accordingly in the timescale. Did anybody else experience this?



Best Answers

  • @Misbah ,


    So good news and bad news.  Bad news, I was able to replicate exactly what you did and I am honestly not sure why it is behaving that way.  Because, and the good news, is it doesn't behave that way in NUX.  Take a look:


    Default view:



    Old UX:








    Now the one workaround I did do and got to work, is create a new line item for Line B stating, if Not DCA Read then 0 else Line B.  Total workaround though.



    Hope this helps,



  • Misbah
    Answer ✓



    It is a known issue as confirmed by Anaplan and here is the workaround


    Excerpts from Anaplan Support

    "Thank you for your patience as I looked into this on my end. Upon further investigation, it seems like this is a known issue within the Classic UX that has been fixed in the New UX, however I did come across a workaround that can be implemented within the Classic UX  that I'd like to share with you : 

    1. Create another boolean line item and set formula to TRUE,
    2. Create another line item with the same settings as that of the line item used for the graph,
    3. Give the above line item the formula "IF <dcaDriver> = TRUE THEN <originalLineItemForGraph> ELSE 0",
    4. Create a filter which only shows the values based on your boolean line item (created in step 1) being TRUE,
    5. Save this as a saved view,
    6. Within the saved view, select the line item you created in step 2 and use this to publish a new graph to the dashboard,
    7. Change your boolean line item's (created in step 1) formula to "<dcaDriver>".
    The dashboard graph should now display correctly. Only the values visible due to DCA settings should be visible and the axis labels should also be correct.

    Outside of the workaround listed above, the primary workaround here would be to use the New UX instead as this issue does not occur when utilizing the New UX instead. I'm afraid it seems like there are no current plans for this issue to be fixed in the Classic UX. I do apologize if this issue is a source of inconvenience."


  • @rob_marshall 


    Thanks for your time! But the intention of using DCA was so that I could avoid having a Flat line for Line B which are showing zeroes before the Non Zero Value. The workaround that you have shown is actually the reason for me using DCA so that I do not get a flat line for Prior Months Zeroes.


    Hope that makes sense



  • @Misbah ,


    I totally agree, it is not a good workaround but it is a workaround.  I would enter a support case showing not only your example of it i not working correctly, but also it working correctly in NUX which demonstrates it is not a modeling issue but really a graphing issue.





  • @rob_marshall 


    Any update on this?

  • @Misbah ,


    No, I don't have an update, did you enter a support case and if so, what was their update?



  • @rob_marshall  I thought you said you would do it. Apologies for that. Let me do it right away

  • @Misbah ,


    Sadly, customers and partners get better traction than I do.