Anaplan picking up double quotes instead of single quotes in a line item name


Hi all,

Just wanted to check if anyone else is also facing this issue. off late if a line item name is having single quote (') in it, then if that line item gets referenced, Anaplan replaces that single quote (') with double quotes (") in the target place.

I faced this issue while drafting a complex formula in notepad and copy pasting it in Anaplan. but i checked and found that this happens even if you reference a line item directly in Anaplan.

Attached is a screenshot showing the same.

Hope this can be investigated and corrected in future releases.




Manu Mathur




  • HI @manu.mathur,

    I think this is how Anaplan intended to work. If you have any special characters in the name then Anaplan will automatically add quotes to the front and back. It is not only for a line item but also for module names, list names, property names etc. 

    I hope this helps!!


  • Hi Kavin,
    This is not the case here. The quote is not getting added to front and back to the special characters.
    I have used other special character line (eg: €), and there the quotes were not added. In my scenario, the quotes got added only at the end (not at front), and a single quote gets appended only at the end.
    The scenario that you have mentioned is agreed but is a different scenario.

    Kind Regards
    Manu Mathur
  • Hi @manu.mathur 


    I have never seen this before but I assumption is that having the single quote in the name is interfering with how Anaplan works and this is a very unique case. This may be something to raise with anaplan support and they can advise on whether this is a bug. 


    As @kavinkumar explains if you have a special character in a name it will always add quotes to the front and back of the whole name in a formula and not just the special character. From your screenshot it appears to be doing this but adding double quotes to end and it may to do this to differentiate the single quote you have in the line item.


    Have you tried using a different special character like a ? / or -  and seen if you have the same issue? 







  • Hi Usman,
    I have tried other special characters, but this additional quote is appearing only when having a single quote special character ('). The single quote need not be at the end of the line name but could be anywhere in the name.
    I have raised it in the 'Idea Exchange' portal.

    Manu Mathur
  • @manu.mathur thanks for sharing this. To be honest, I've never seen this before partly because, for my line items, I try to avoid special characters and emojis, @DavidSmith's  Planual even suggest emojis be avoided - page 20. 


    But, the double quote you mentioned is actually two single quotes. I believe this is the escape character for Anaplan.

    I replicated it and discovered you can get this to work if you use two single quotes.


    Created a source module with line item and line item value using a single quote.


    Displays correctly.


    Using a formula I referenced the source but used two single quotes.

    Works perfectly.