Data Integration From Sharepoint



We have a scenario where  we want to load data files into Anaplan Model. Needs some suggestions.

Option 1.

- Input data files are available on sharepoint.

   Do we have a way of data integration from Sharepoint to Anaplan?

Option 2.

- Place  the file on P:/Drive (Network Drive) and run a batch job via schedule to pick the file and load into Anaplan. Can Anaplan connect be used to load the file? if yes, then where we have to install the Anaplan Client.





  • @rajuvendra01 

    Great question. 

    It all comes down to the email address you use for your authentication. This same address must have access to the SharePoint site or your P drive.

    If you use basic authentication (user ID and password) your email ID will need network access as well. 

    From there you can use a variety of integration methods: anaplan connect, one of the native connectors in an ETL tool like Informatica, Dell Boomi, or Mulesoft, APIs, or manually.

    Long term, this is not a recommended strategy though for data integration as passwords change, ensuring your pwd is encrypted, etc...

    Long term, the best approach is to use a CA certificate. There's lots of documentation on the site here that will help you with that.


  • Thank you Jared for the details. I tried testing Anaplan Connect from P:/drive.


    As part of test, I have unzipped the Anaplan Connect 1.4.3 setup folder on P Drive and created a sample Bat script to trigger an Import action but script failed because SSO is enabled on workspace.

    2020-01-31 20:45:33 ERROR [c.a.client.Program :654 ] 198792 |-- Anaplan API: Basic Authentication failed! (Feign: status 401 reading AnaplanAuthenticationAPI#authenticateBasic(String); content:
    {"status":"FAILURE_BAD_CREDENTIAL","statusMessage":"Authentication Failure.


    Can you please point me to a documentation which tells how to create a bat script if SSO is enabled and what parameters are necessary to pass?




  • @JaredDolich 

    Thank you for the details.

    When you say SSO needs to be turn off. Is it like an exception ID which we can create and do not provide "Single Sign On" access from USERS settings in model?

    Can we use "sample_basic_auth_import" sample script (Anaplan conect setup example script) to connect post above user settings and trigger any action in sample model ?

    I tried above steps but somehow still getting the authentication error message.





  • @rajuvendra01

    You'll need to be a workspace admin (WA) to to this but my best suggestion would be:

    1. Open up the model that you're trying to import data into

    2. Go to users tab

    3. On that first tab that lists all the users you should see a column with SSO as a Boolean

    4. For only the email that you are using to import data, you will need to temporarily uncheck SSO

    5. Then you will be able to use basic authentication assuming that email ID has import permission (best to set this as a WA)


    You cannot enable or disable SSO from outside of Anaplan. Well, at least not that I'm aware of.


    I will sometimes use Postman or Python to test the permissions of an email ID (assuming I have a password or certificate on that email). Something you can try too before running the Anaplan Connect script. I will usually just see what import actions that email ID has permissions to run.

  • @JaredDolich 

    I have followed the exact same steps as you have mentioned earlier and using the Import batch script which comes with setup for basic authentication.But somehow still getting below error:


    2020-02-03 23:59:42 ERROR [c.a.client.Program :654 ] 105992 |-- Anaplan API: Basic Authentication failed! (Feign: status 401 reading AnaplanAuthenticationAPI#authenticateBasic(String); content:

    {"status":"FAILURE_BAD_CREDENTIAL","statusMessage":"Authentication Failure. If you're unsuccessful after multiple attempts, your account may be locked. If you are using the Anaplan login page, click the 'Forgot Password' link. Otherwise, contact your Anaplan administrator or Anaplan Support."})


    My model role is "Full Access" and I am a Workspace Admin.


    I am using below mentioned default parameter present in script, do I need to change them?


    set ServiceUrl=""
    set AuthUrl=""




  • @rajuvendra01 

    Let's try a few things.

    1. Can you provide a screenshot of the script you're running (remove or mask out any userIDs, passwords, workspace, model, and action identifiers). We'll check the syntax.

    2. Do you have a Python environment? - I can send you a script that will confirm where you might be having problems.

    3. If not, do you have Postman set up? I can additionally send you an example of how we can validate where the problem might be.


    Lastly, just make sure you can log on with that email and password and that the SSO is unchecked for that same email you're using to import the data.


  • @JaredDolich 

    - Script Screen shot attached.

    - Python/ Postman environment is not set up.

    - I have unchecked SSO for my email Id in Model and I am workspace admin. But still I am able to go to Model selection page without giving my credentials (Looks like some authentication is happening automatically).


    Just fyi, I am not using Normal Anaplan URL

    link to login. I am logged into customer network and there is active directory setup to launch any application and  Anaplan application is one of them. It directly takes me to Model Selection page.




  • @rajuvendra01 

    Awesome. Unchecking the SSO is what's called an "exception user" which is what you'll need once SSO is turned on.


    In looking at your script I noticed two things you might try. If neither of these help you then you might want to log a support ticket to You'll get a prompt response. 


    The first is the "set AnaplanUser". I know you sanitized this script but just wanted to make sure it's in the format

    set AnaplanUser =


    The second thing I noticed is that your script below the edit line is missing the workspace and model ID

    set Command=.\AnaplanClient.bat %Credentials% -workspace %WorkspaceId% -model %ModelId% %Operation%

    Try putting those back in.


    The only other thing I can recommend is to download a free copy of Postman and test your emailID using the APIs (for now, preferably v1) and use basic authentication to see what workspaces are open to that address.


    Good luck! I'm sure this is an easy fix. Just have to find the right spot. Make sure you post the solution once you have it! We can all learn.