Level 1 Source to Target Mapping Part 7


In the Importing Data Modules Activities for Employee Details, I'm having issues matching the employee names with the source.  It does not recognize the employee name in the 2nd tab ( "#E2 Employees") and therefore does not match the names.  See Screen Shots. 


  • @SusieSchmidley 


    This is because this is a numbered list vs a standard list.  Because of this, the system will generate an ID for the name and you will import off of the code, while using a display name property for end users to see.    Re-watch the Microlesson on importing into lists, it will discuss this exact issue under Importing Errors. 

  • So this response explains why the problem exists, but I don't see how it rectifies the issue.  If the module imports can't map the data to be imported automatically to numbered list display names, it seems to me to be a strong disincentive for using numbered lists. 


    Honestly, I'm having trouble really seeing the value proposition of Anaplan-managed numbered lists at all.  While it's certainly valuable to have guaranteed uniqueness in one's key/code, It's often desirable for that unique key/code to not be a simple serial number starting from 1.  the micro-lesson sets the code to the SKU number, and that provides enough uniqueness on its own.  Systems like SAP can assign unique numbers to new master and transactional data entries (e.g., inventory material numbers and sales order numbers, respectively) within a range while still being random enough to make fraudulently fabricating a valid number difficult for social engineers/hackers.


    I'd love to hear someone succinctly sell me on the value Anaplan-style numbered lists, because being unable to import data in situations like what the OP (and I) encountered would be daunting indeed if the list were an order of magnitude or two larger.

  • If I understand Chrised209's point, to import into SYS08 Employee Details we need to manually map each record as shown in the attached screenshot (I only partially completed the manual mapping).




    Screen Shot 2020-04-05 at 2.15.58 PM.png

  • @davidmccarty 


    Precisely.  For the ~100 employees of UCC, this is merely an annoyance; for a company of several tens of thousands of employees, this simply isn't feasible to manually map anymore.  

  • @chrised209  @davidmccarty 



    I would recommend reviewing these Microlessons.  You don't have to manual map, you use the code on the import when you are using a numbered lists.  


    A standard list has two ways you can identify a member of a list, you have the Name and Code fields.  A Numbered list is used when the Name field for every item is not unique, for example you could have two employees with the same name.  Because the name field is not guaranteed to be unique, you map by the Code field.  







  • @filip.sypniewski@davidmccarty,@ChrisMullen 


    Yes, that does the trick.  


    I can now tell you exactly why this is a point of confusion.  The lessons that are linked in your post all speak directly to the list import process and not the module import process (which is where I'm hanging up). The lessons make very clear how the numbered list import is supposed to be executed, and my list works perfectly.


    It's in the mapping of the data file within the module using the correctly imported list that I was hanging up.


    The module import Mapping tab asks for the source data to match the target, which is this case is given here:

    Module import point of confusion  cropped.png


    Note how strongly the UI cues the user to incorrectly select Column 2 for the source identifier by not only matching the column name (which is admittedly coincidental here), but also the fact that it prompts the user to select a column that contains actual names rather than codes as found in Column 3.  This confusion is further confounded by the Details specifically prompting for the Code to be handled by the second source identifier.


    In the linked microlessons, the training materials take pains to emphasize this... I'll be kind and call it a quirk... of the interface during the list import process, but there is no such analogous emphasis for how to modify things during the module data import process.


    Ideally the UI would recognize that it's trying to populate a numbered list and prompt the user to map to the code data and not the display name data, and the training example would compel the user to "get it right" before moving on by providing, e.g., two employees in different departments with the same name. I moved on after manually mapping in large part because the training materials didn't force the issue of resolving the non-uniqueness at the time.  Had it done so, I would likely have tinkered around and tried using the code against the guidance of the UI to clear the errors.


    I'm trying to move on and finish the L2 curriculum, but it would be nice if someone else would be so kind as to reply with the relevant microlesson that talks about module data imports against a numbered list.


    I hope the above makes my (and I suspect @davidmccarty 's) sticking point clear and why the referenced microlessons don't speak to it.


    Thankfully this is all moot to me now, as I see how to successfully execute the import, credit to @filip.sypniewski.  

  • @ChrisMullen @filip.sypniewski @chrised209 


    Thanks for the responses.


    I redid the data import and it all worked fine.  I could have sworn yesterday that I tried to use the code on the import but couldn't get it to work.  Not sure now what I was doing wrong but this morning did it successfully.  It also solved my issue of the name of the employee not showing up.


    @chrised209- I did have a question for you - why in your screen shot of the data import do you have a column called "#E2 Employees" in the Employees.csv?

  • @davidmccarty 


    You don't?


    Here's how my list import looked (maybe I have more of a problem than I'd thought:

    Employee List Import detail.pngEmployee List Import detail.png

    Post-import #E2 Employees list.png


    And here's the blueprint for my module:


    SYS08 Module blueprint.pngSYS08 Module blueprint.png

    @ChrisMullen @filip.sypniewski 


    Does all of this look like it's expected to look?



  • @chrised209 


    I compared your screenshots with my Level 1 model and indeed it looks exactly the same. 


    The only differences I noticed are following: I can see Code in Column 2, Active? in Column 9, as well as my codes are 001 instead of 1. Though, these of course do not make any difference.


    Let me know if you have other questions! 

  • @filip.sypniewski 


    Mostly I'm just curious as to why @davidmccarty 's mapping view doesn't line up with mine. 

  • @chrised209 


    I understand your point. I am pretty sure that I followed a video once in which import into modules was explained in details. I cannot find it at this moment, but maybe @ChrisMullen will identify it quickly. I think you are free to share also your feedback with Academy team and help make the courses better for everyone!


    In the file that I just downloaded from Level 1 course and tried to load in to my list, I did however not see the second column "#E2 Employee". Can you check that and download the file again? Indeed it might be misleading for you. I can see Column 2 being a Code.


    At this moment, sharing the article in which import into modules with numbered list is also explained, but I will get back if I find corresponding video.


  • I am sure it is due to the file that you are importing. See my other post in this thread that I just published. 


    When I download the file I do not see "#E2 Employee" as a second column. I think it's the same case for David.

  • @filip.sypniewski @chrised209 


    I will compare my modules to yours Chris here shortly...but here is a screen shot of my Employees.csv (I downloaded a few times thus the number in the name - Mac added that automatically)

    As you can see, no #E2Employees column


    Screen Shot 2020-04-06 at 11.45.05 AM.png

  • @chrised209- I checked my SYS08 Employee Details module - looks just like yours.  Unfortunately, I can't compare my #E2Employees import settings since I lost the settings while I was testing some other things

  • @davidmccarty 


    Ah, I remember now!  I added that column with the names in single quotes to the CSV file to see if the text delimiter being correctly interpreted was important to the import process.  Turns out it wasn't and it was ultimately superfluous.  I need to rerun the module import without my added column and see how much crow I need to eat to correct my earlier post about UI trickery....

  • @davidmccarty @filip.sypniewski@ChrisMullen 


    Okay, My original position is only slightly weakened now that my manually added column is absent.  


    The UI is still prompting for a column that contains display names instead of codes, I'm just no longer able to select the column name that has the list name as an option since it no longer exists.  Following the UI cues still leads one to select not the needed Code column but the unhelpful Name column.



    I recommend an update to the UI for this module data import mapping tab that checks whether the target list is numbered, and if so prompts the user for the code column by giving examples of not the first few display names, but instead the first few code values.


    Change the Target guidance for the first source identifier:


    "#E2 Employees (Shiala Engle, Otha Mahan, Sindy Wager, ...)"




    "#E2 Employees (1,5,8, ...)"


    and the end user will have a much clearer cue as to the expected inputs to allow for automatic mapping.  Making the user consciously pick a column that contradicts what the UI prompts for is, IMHO, sub-optimal UX, especially when the conditions when the contradiction occurs are so clearly defined. 

  • @chrised209- I like your suggested UX improvement as that is what partially threw me off yesterday when I was getting stumped....

    Thanks for all of the help!

  • RongF

    a follow-up question:


    there seems no setting for the format of start date and leave date on the screenshot...

    I am wondering if there is any point that I missed..

  • @filip.sypniewski "as well as my codes are 001 instead of 1. Though, these of course do not make any difference."


    This did make a difference for me.  I had to go change the formatting for the Code column in the source file to Text and then copy/fill 001, 002, etc. to get the auto-match to work.  Maybe I'm not understanding something, and I eventually got there, but maybe others will have the same issue so I thought I'd mention it.

  • I'm struggling to understand what I'm supposed to do about the date formatting as well (other than just change it in the source data). In the videos, there is a Time tab that you can access if Time is a dimension, but here it is not.
  • RongF
    I just figured out!
    Select the checkbox next to the start date and end date,
    you will see the format window pop up!
  • Thank you so much!!!