Dashboard - Unable to edit


I was able to edit the dashboard a minute ago.  Then I went else where in the Model to view.  When I came back to the Dashboard, I was not able to edit.  No changes were done in the Dashboard.  I tried another Model and encountered the same problem...i.e. all of a sudden, I could not edit Dashboard.

Appreciate any help.



  • Did you make any changes in the page selectors? I mean you need to be at the lowest levels of hierarchy on the dashboard to input any number- unless you are using breakbacks. Check and let us know if that is not the case

    Hope that helps
  • @Misbah 

    It wasn't to input number.

    I wanted to change the Dashboard design and I have Workspace Admin rights.
    Does it matter whether lowest levels of hierarchy needs to be selected at the Page Selectors on the Dashboard?

  • Can you please post snapshot of your dashboard. If you are an admin you should be able to make changes.

    Selection of page selectors matter when you want to input number on the dashboard otherwise it doesn’t matter in designing the db
  • @Misbah 

    Please see below the screenshot.  Thanks.




  • Hi @Star 


    Click on the dashboard symbol then you will be able to edit the dashboard








  • @Akhtar.shahbaz

    Hurrah!!! It worked. 🙂