Unable to map module /csv

Hello Everyone, 


I am trying to import a csv file in my module but having troubles with the mapping for one of the columns when I tried to do "Match on names or codes" all the items are ignored and when I tried to map manually it doesnt allows to pick any value from the target items.

Please see below screenshots for reference.


Any help will be appreciated. 










Best Answer

  • JaredDolich
    Answer ✓


    So close!

    Try looking at your P2 List. This is what you should be mapping to.

    But, I just looked at my model and the DAT module should be P3. Something is off with your file. You should be getting SKUs.



  • @alkamani   


    Take a look at this microlesson https://community.anaplan.com/t5/On-Demand-Courses/Import-Errors/ta-p/63659  


    You'll see we cover exactly the error you are facing!  Any time you see that (...) that means that list is not populated.  




  • @ChrisMullen Thanks for your reply. 


    Unfortunately I didnt got the fix for my import issue. 


    In my case it simply ignores the SKU column there is no error whatsoever. 

    Not sure what exactly the issue is here 😞 






  • The lesson states that it you see the (...) your list is not populated.  Did you check your SKU list to see if it is populated?

  • @JaredDolich 


    P2 List worked for me ! Why P3 didnt worked is still a mystery but anyways P2 is giving same results so I am good. 


    Thanks Jared, appreciate your help.



  • @alkamani 

    yep that's because the list items in your DAT CSV file was using P2.

    But @ChrisMullen is correct. I just checked my L1 model - When I look at my DAT module I imported at the P3 level. 

    I'll have to do some research here, but I'm wondering if maybe you have an old CSV file. 

    Well, anyway, glad you got that to work. 

    In all the courses you should ALWAYS get a green checkbox with no ignores or errors.

    If you do, re-read the documentation to see what might have happened.

    You can always ask here too!

  • @ChrisMullen  SKU column is populated.






    It is latest csv from the Level 1 course exam. 


    I completed the full Level 1 course without any issues however in the Level1 exam the import steps for csv are giving same troubles.



  • @alkamani   I just downloaded a file from the exam and it was different.  Are you sure you are using the correct file?  It should have sku level data so your items should look like this 

    Nutzo Bar_EN
    Raising the Bar_EN
    Cookie Crumbs_EN
    Do-nutty Buncha Munch_EN
  • @alkamani 

    Yeah, the file @ChrisMullen  shows is the right one!

    I'm wondering if your file is from the original level 1 course.

    Click on the link below and make sure it's the same one you're working on.


  • Hi @ChrisMullen @JaredDolich  


    That's correct the original file had language suffix at the end however I had removed it while I was troubleshooting the import issue.