Possible error when copying Supply Chain base model to my personal workspace


Hi -

Am working on Sprint 2 of the Level 2 Model Builder course.  I am at the step where I need to pull historic volumes from my Data Hub into the Supply Chain model.  In running the action to import the data, I ran into several issues.  In digging into the problem, it looks as though the source objects still have **Your Name** in them versus my name when I copied the model.  See screen shot - I fixed 9.1 Import Historic Volumes but you can see most of the others are incorrect.  I did a search through all of the steps and didn't see where I missed taking some sort of action to change the names. 

Question:  Did I do something wrong when I copied the model?


Screen Shot 2020-04-17 at 8.00.52 AM.png


  • In the Settings gear, click on Source Models, click the Data Hub **Your Name** and then click Edit Mapping at the top and map it to Data Hub David McCarty.


    Hope that helps!

  • @kathleenseiler- Thanks!  So what I should end up with looks like this?

    Screen Shot 2020-04-17 at 11.07.23 AM.png

  • Hi @davidmccarty,


    **Your Name** are the default Import actions which you will get while downloading the model. If you encounter any errors when running the actions, kindly remap your Source to the correct model.

    Example: Level 2 Data Hub [XXXX] / 'DAT03 Historic Volumes'.Export




  • @davidmccarty Yes! Now if you try to run the import actions you shouldn't have any issues as all the data should be pulling from the Data Hub with your name on it now.

  • ANS

    @SathyaM ,

    Remapping the source to correct model solved the issue. Thanks a lot for that.

    However, I still wanted to understand the reason for remapping the source model.

    At the end of Sprint 1 and before starting Sprint 2, we are asked to map the Source Model(Data Hub Model) from the Target Model(Supply Chain Model).This should take care of mapping from Target to Source.


    My understanding from the above screenshot is "Level 2 Data Hub **Your Name**" is already mapped to "Level 2 Data Hub_Narender". That means system knows:

             "Level 2 Data Hub **Your Name**" = "Level 2 Data Hub_Narender"

    Then, why the process is getting failed when we run "Import Data from Hub" action?


    Furthermore, I am able to edit other pre-existing actions like "2.3 Import Size", "9.2 Import Opening stock" etc., but not "9.1 Import Historic Volumes" from the Action tab. Which does have the same source model name "Level 2 Data Hub **Your Name**". Please check the screenshots below:




    Thanks for you help.