L2 Sprint 1 Countries Flat File import


Having some problems re running my countries flat file import. Is this the view I should be importing on? Also these mapping continually give me errors. Any help is appreciated. 


Screen Shot 2020-05-06 at 10.37.33 PM.png



  • Hi Mhinnes,


    This doesn't appear correct.


    By importing column headers you are basically importing the every column of the first row as a "name". This should be column 2 "Country name"

    You are also importing the column name as a code. I would expect the code to be column 1, but you'll need to verify that.


    I tend to open my source-file on the screen next to me when importing data into lists or modules. This helps you visually to identify where the information is supposed to  come from.


    Good luck,

  • Hi Mhinnes,


    As mentioned previously it seems that the mapping is not correct. I would think that in your source file you have name, code and parent. 

    Name should go to name, code to code and parent to parent. Column header should not be mapped in this case. 


    Hope this helps. 

  • @mhinnes 

    The Country flat ( and all other first line when importing a list) represents the items that will make up the list. for example here,  that would be the column in your source (CSV file) that contains the country names. You have to be specific when mapping.
    I have never seen Column Header used when importing into a list. I'm not even sure the option should be available (correction??)

    Anyway, once you map the column containing the names of the countries ( I assume it's Country Name you mapped to Code) the import should work.


    Note: Unlike when importing to a module, you can map the same column in the source (your CSV file for example ) to more than one element in the target list.
    For example, if you don't have a designated Country Code in the source file then you can map Country Name To Code.

  • mhinnes

    Thanks the tips really helped

  • mhinnes

    Thanks the tips are really helping. 

  • mhinnes

    Thanks the tips are really helping!