"Error" message using Import to clear user input date data


Hello, Community


In a daily replenishment planning model I've recently deployed for a customer, everyday, the planners may need to manually override below line items (format in brackets):


ADS Values (number)

ADS % Changes (%number)
Cancel Order? (boolean)
Manual Order Input (number)
Override Delivery Date (date)


Hence, I created a clearing process to clear out previous day inputs every morning when they refresh the data

1. Built a clearing module with 5 line items matching the same data formats as target line items (listed above)

2. Keep data fields as 0/false/blank

3. Run import from target module to pull data from the clearing module

The actions work perfectly for the first 4 targets. For clearing out the dates, an "error" message attached in screenshot will appear. I double quoted the error because in fact, the dates are cleared out successfully, yet Anaplan is throwing the message.


I have played around with different options with date formats or set as No Data, but the "error" message still exist. For now I put it as the last step of the process so that it won't affect other actions and asked the customer to ignore the message. But definitely this is not a preferred way to handle this.


Not sure anyone encountered such situation before or it is a platform bug. Any insights/workarounds will be appreciated.




  • Harsha

    Hello @tingtingxia 


    Instead of creating another new module to clear the line items, create blank line items in the same module and import from saved view to saved view. In this you won't get any dimension issue.


    1. To Clear few line items for all the rows, you can create another line item say "CLEAR" with "No Data" format and create saved view with only clear line items. 

    2. Import into same module with clear saved view. Map CLEAR line item to the line item which you want to clear before importing. you can ignore remaining which you don't want to clear.

     Note: You have to create multiple CLEAR line items to clear the multiple line items. 





  • SathyaM

    Hi @tingtingxia,


    Please find below the screenshots. I have created "Clear Values" module and marked as "No Data" for all the line items. 
    Kindly check your Import action mapping to fix the error.







  • Hi Harsha


    Thanks for the reply.

    I tried this method also. The dates will get cleared out yet Anaplan would still give the "error" message. You may refer to the screenshots I shared for the mapping details. 

    Screenshot 2020-05-12 at 2.23.51 PM.pngScreenshot 2020-05-12 at 2.24.12 PM.pngScreenshot 2020-05-12 at 2.24.31 PM.png

  • Hi Sathya


    Yes, mappings are correctly done. I am not sure:

    1. whether is it related to subsidiary views in target module

    2. if it is related to Point 1, why only throwing "error" message for dates clearing while others are run smoothly.


    Best Regards

  • SathyaM

    Hi @tingtingxia,

    Please try the below method.



    Create an import action to load Clear (No Data) into all the other line items. Make sure to click on "All items" in the mapping.


    All the values got cleared!





  • Harsha

    Hey @tingtingxia 


    Subsidiary view created in the module causing the issue. Its not just for Date format.  Even if you hide it in saved view, you'll get this issue. 

    When you trying to import from same module, instead of selecting "Not applicable to this import" option, try to map subsidiary view list to the same line item. 


    Action will run without any errors.




    In My case, column 5:task is subsidiary line item with list Parent. So I mapped the same.  










  • Harsha is probably right, date line item might be a subsidiary view, can you confirm ?
    Can you show us the import mapping ?
  • Harsha



    Subsidiary view which is present in the module will throw this error when you select "Not Applicable to this Import" while importing. 


    I have created this module to replicate the issue what is mentioned above :  I am mapping CL_Date line to Date line item to clear the value.

    Task line item is subsidiary view with Parent list. 


    This is import selected for Parent list:  Even when we hide subsidiary line item from the saved view, we get this option.


    When you run this action, import will fail with this error.









  • Hi Nathan @Harsha 

    Below are line items related to that Override Delivery Date (target to clear). This specific line item is not a subsidiary view, but I have a Today Date which is dimensionless. 

    Screenshot 2020-05-13 at 9.34.59 AM.png

     My current mapping (shown to Harsha before) is as below and my question is how I can bring in other 4 dimensions for mapping? Currently in my dropdown list I don't have the selection.

    Screenshot 2020-05-12 at 2.23.51 PM.png

    Screenshot 2020-05-13 at 9.55.30 AM.png

  • Hi @tingtingxia ,


    As I can see in the Screenshot . there is only one dimension (P5 SKU SS: National) with 2 line items (Today Date, Clear Dates) in the Source Module from which you are trying to import into the target.

    that is why you are not able to see other dimensions in the dropdown.


    Can you please show us source Module where you have created line item "Clear Dates" ?





  • Hi 

    I created the line item in the same module as the target line item to clear following @Harsha 's advice at the very beginning, meaning both line items are in the same module.




  • Harsha



    why don't you show subsidiary line items in the saved and map those items to list. 


    When I replicated your scenario, task is the line item which has subsidiary view. 

    When I selected this option, I got the error what you are getting. 


    So I showed that line item in my saved view and mapped task line item that list. After this action was successful. 







  • @Harsha  

    Understand that. But my subsidiary view line items are crossed with 2 dimensions as below. 

    Screenshot 2020-05-13 at 8.11.32 PM.png


  • I had the same error as the author of this post, and selecting "All Items" in the line-items mapping section solved my issue. Thank you!