Item name must be mapped-error message



I have the list comp_pr_po_supply and trying to import data from the datafile in my computer. During mapping, I am getting the message ,Item Name must be mapped for the property comp_pro_po_supply.  

I assume I am getting this message because comp_pr_po_supply has been setup as a list item. But, I don't find that in my setup. Can you help me to decode this error?







  • Misbah



    Your list is a general list and not a Numbered list hence it will ask you to match first mapping (which is Name), hence the error. If you want Anaplan to create a unique key(which is no way a best practice) convert the list into a Numbered list and then load the data.

  • praba71

    Thanks @Misbah  for the quick response..

    I do not want the numbered list and want to match the first mapping to the property 'Unique'. Can you guide me how to set that up?


    Thanks again

    Prabakaran v


  • Misbah



    My Solutions would be


    Please stay away from Combination of Properties and get  a unique code for each entry 

    If you have to use combination of property then your list has to be Numbered List & not General List

    If you don't want to use Numbered List then there is another option - But I don't advocate that to anyone.



  • hi @praba71 


    you can create unique item name in source file and map that to the name column , however here there is a limit of 60 characters length as it is a general list, you need to populate the name of list items as anaplan generates items based on the name as it must be unique, duplicates will be ignored