NUX - Field Card - Input number with decimals as percentage gives error


Hi guys,


While adding a Field Card in the NUX, the user can't input a % that has multiple decimals (ex. 1,49% or 2,99% etc) and it gives an error (3rd image).

In the model the number looks fine and it is calculating as expected (1st and 2nd images).

  • Do you know why we have this error in NUX? 


Module view of the %



Module blueprint details for "Test LI %"



NUX view of the %




Thank you!



Best Answer

  • filip.sypniewski

    Hi @Constantin,


    I think it depends on the settings of your line item. You can set decimals separator as comma or dot. That is being taken for the NUX field input:



    I can see, the comma or dot on the lines, however it is still not possible to input anything for the one with comma. So indeed it seems like a bug and good to contact Support Team!


  • Misbah



    Yes, looks like some sort of bug. I recreated it and I got the same result when published in Field card, however it works fine in Grid Cards. You can raise a ticket with and request them to investigate this

  • Thanks for checking it out! I'll drop an email to the Support team.
  • Hi, 


    I indeed encountered the same problem before. For some reason, it works fine if you use "." as decimal separator instead of "," (at least it did for me). 



  • Hey Filip,


    Thanks for your feedback! The Anaplan Support team just confirmed it is a bug and indeed, the solution is to set the decimal separator to "dot" instead of "comma".