Error in Import - Expected 2-digit month number in date/period

Hi Guys,


This might be simple but I do not get why it is having an error. So I have 2 identical modules. I have IC PNL and AIC PNL. They are both identical in terms of dimension and line items. So what I am trying to do is import IC PNL to AIC PNL that simple. Whatever numbers is in the IC PNL should be the same as the numbers in AIC PNL. I am getting this error, see below:






This is the current settings in TIME that I have. I tried the custom format as well as match names and it is still not working.



And also the figures are doubled up. ANy ideas on this issue?




  • @Jsdeloria21 

    Map Time dimension by Match Names as you are importing module to module.

    Else still problem persists use Custom time option available in import action in the bottom, type there (for example:MMM-YY or YY-MMM)


    Hope this helps



  • @Jsdeloria21 


    If you are using the same timescale in both the modules then you should map the imports on Match Names.

  • Hi,


    Appreciate the quick response. I tried Match Names earlier and it popped up and error. So i tried the custom period MMM YY. same error comes up






    Are you using time ranges..?

    could you please share the screenshot of source and target module.




  • Hi Misbah,


    Appreciate the response. They do have the same timescale, however, in the IC PNL module we have a dimension which we do not need to use in the AIC PNL. It is the process flow dimension. Is that why I cannot use the match names?

    Highlighted below is the dimension I am talking about. This is not present on the target module since AIC PNL will have a different version. Is this why I cannot use the Match name option? Because the error with the match names it prompts on looking for that dimension.






  • Hi,


    We are using the same time range however there is a Dimension in the IC PNL which is not needed in the AIC PNL that we removed. 

    See below.


    This Dimension is only present in the IC PNL but not on the target AIC PNL. Is this what is causing this problem? We cannot include this column because it is not the same version as AIC PNL. I hope that makes sense. So in the mapping part we removed it. 




    Any ideas on importing the data to a Target module without this version present?




  • @Jsdeloria21 


    Yes it is because of that extra column. So what is happening here is Anaplan expects every column apart from Column 1 and Column 3 to be Time Formatted because Time is kept as Column headers, hence the error. 


    Why Import? Why don't you control with the help of formula? Are you taking a snapshot?

  • Hi @Jsdeloria21 ,


    Try using pattern with separation Y-M because in the mapping your target is showing in YYYY-MM format

  • As @Jitendra.Vishnolia mentioned try mapping Y-M. Else use custom time.YYYY-MM.

    As per the screenshot shared the time format in the source module is YYYY-MM.(Highlighted below.)




  • Hi, 


    As mentioned I changed the format to Y-M and custom format YYYY-MM and this is what I got. 

    From Expected 2-digit month number in date/period. The prompt now shows 4-digit year in date/period.



    Does this also explain the sudden increase in the figures after it is imported in AIC PNL?





  • Try This.


    Create a saved view in the source module, lists in page selectors,line items in columns and time in rows.

    Then create an import action and run.


    Hope this works.