Copy and paste in NUX


Hi Community,


I want to copy 4-5 values from a excel sheet and paste it in a specific editable line item on the NUX dashboard.

I am not able to achieve it.

Is there something i am missing to achieve this/ how can this be done.?


Thanks in Advance.


Best Answer

  • Misbah
    Answer ✓



    For me it works although there is a lag and is not as efficient as Classic UX. Also I didn't have to double click in a cell and paste it.


    As others suggested let Anaplan Support take a look at this and share the feedback.


  • Misbah



    You can use Ctrl+C and Ctrl+V Option.It works


    However there is one missing thing in NUX. It doesn't alert users if the cell is a read only and you try to input the number in it. This feature is available in classic UX.

  • @Misbah 


    I have used CTRL+C and CTRL+V, but it doesn't seem to work.

    And the cell is not read only,As  it is part of a input lineitem with allow editing activated.





  • Misbah



    It should. We do it on a daily basis whether it is classic or NUX it works.


    Try clearing out your cache from your browser or try diff browser and see if that works

  • Thanks @Misbah 

    Will try this.

  • Hi @abhi1017,


    what is the format of your line items in Anaplan? Maybe you are trying to paste something that is not accepted by Anaplan? For example, line item is list formatted, and you are trying to paste element that does not exist in the list. 

  • @filip.sypniewski 

    Its number formatted breakback enabled lineitem.

  • Hi @Misbah 


    The Copy and paste is working for only single cell at a time but the client wants to paste values for 4 cells at once from excel.

     Lineitem where the values are to be pasted is breakback enabled.



  • @abhi1017 

    I just made a simple example with the same case as yours.

    So, I can paste the values when current value is 0, however I cannot paste anything when there are numbers already and I would like to overwrite them. 

    Did you experience the same? I think the best way would be to contact Support Team so they can look into it.

  • @rob_marshall @DavidSmith 


    Could you guys pls. help me with this. 

  • Misbah



    Here is my analysis on it.


    Breakback functionality allows you to change the numbers which otherwise you will not be able to change. For example changing the numbers in Q1 and anaplan re allocates the numbers for all the 3 months of Q1. Let's say if we want to copy paste the numbers in all the three months of Q1 as well as for Q1 itself ( making the count as 4) it will throw an error in Classic UX 

    Numbers I wanted to copy paste 

    Jan  = 1300

    Feb = 1230

    Mar = 1430

    Q1 = 1540



    Error is valid because it doesn't make any sense that you input values for all 4 which doesn't tie up at all. (Q1 is not summing up with Jan, Feb & Mar)


    In NUX: these type of alerts are missing.Making you think that the copy paste doesn't work

    Now, In order to validate it here is what I have done:

    Case 1: I have copy pasted just three values and below is the result. (Q1 being an input because it is breakback enabled cell).


    Case 2: Let's try to input all four but Q1 matches exactly with the summation of Jan, Feb & Mar it copy pastes it without any issue. There is a small lag but it copy pastes successfully.


    Case 3: Finally I tried to Copy paste all the 4 numbers where my Q1 was not matching with Jan, Feb & Mar summation. it doesn't do anything, because it doesn't make any sense if you input all 4 when you parent is not matching with its descendents


    Hope that helps




  • copy paste is broken in NUX and there is multiple cases where it doesn't work properly, like the one you are explaining.


    it is known and the team is working on it but please raise a support ticket nonetheless.


  • @nathan_rudman 


    Already raised a ticket.




  • Thanks a Ton @Misbah. I understand the logic presented.

    But here i need to paste values for only two months at once. (w.r.t example displayed)

    I cannot paste it NUX for two at once.

    In NUX even for one cell for the copy paste to work , i need to first double click it and then only can paste.

    It just doesn't happen like classic UX where in we select the cell and paste.



  • @Misbah 

    I don't know why it isn't working for me.

    Have raised a ticket to Anaplan.




  • @abhi1017 


    Earlier we had an issue with copy and pasting into a single cell without double clicking.  That was resolved by having our users switch to Chrome. 


    However, our users are still not able to copy and paste multiple cells.  

  • @edeblacam 

    I have been facing the same issue.

    I had raised this to Anaplan Support, thereafter our team is able to copy/paste multiple cells with a certain lag of 4-6 secs but the client is not able to do same even in chrome.




  • Agree Fully! It does NOT work