Copying Actions


I have an action to import today's date into a field 'Today' in a time assumptions module, every night using connect script. Great, works perfectly, all is good.
I have a separate action/process that runs ad-hoc, but when it does, I would like to import today's date into another field in the time assumptions module 'Update Date' but I cannot create a new action, as Anaplan assumes I want to edit the current one, and I lose my original mapping. There are 10 processes so I don't want to create 10 separate modules just to hold a date. And I cannot copy/import from one line item in time assumptions to another it seems.

Can you copy actions and edit so the original is not updated?

Can you copy from one line item to another using an import process?

Is there a better way of recording when an ad-hoc process is run?


Best Answers

  • Misbah
    Answer ✓



    If the Target Module has same source Anaplan will not create another import action. Here is what I have done, hope this helps


    Step 1: Created Global Time Module with Dummy List as a dimension (Dummy List has only 1 list item in it)

    Step 2: Created Saved View in Global Time Module and Imported the Date from my Saved View to "Import to Today" line item


    Check the Mappings of this import


    Step 3: Create another module "Global Time Module Backup" and Dummy List as a dimension and create one line item in it

    Step 4: Import the date from Saved View of the "Global Time Module" into "Global Time Module Backup"

    Check the mappings of this import


    Step 5: Refer the date from Backup module into current module with point & click



  • Misbah
    Answer ✓



    Keep your Dummy list in rows and line items in columns.  Dev Model PM is the name of my model you can ignore that


  • anirudh


    Not sure I understood your question

    Are you utilizing saved views for the ad-hoc processes?

    Try this,

    1. Create a saved view in your time assumptions module and give it a unique name

    2. Import into the time assumptions module from the saved view created above, this will create a fresh action instead of editing your original action





  • Hi,I understand what you say, I already tried that but I cannot get it to work at all.

    I have a view which is just the 'Today' which has today's date, and I am trying to import that (view) date into a field called 'Epos Update' in the same module.


    Should be simple!


    I am doing something wrong I know, but I cannot work out what (one of those days)



  • anirudh

    Got you now!

    Unfortunately, you cannot import into a module with no dimensions. Your time assumptions module has no dimensionality (this is correctly set up)
    1. Create another module with a fake list (just 1 member) and just 1 line item
    2. Then recreate the action in your screenshot and import into the new module
    3. Now the action should run fine
    4. Lastly, come over to Epos Update line item and give it the formula:
    FakeModule.LineItem[SELECT: FakeList.'1']

    Let me know if this works


  • Misbah



    Can you show the mapping of your import?

  • Hi, no that failed too, i have tried every mapping option there is... this is frustrating as it should be so simple, and I have 10 processes, do I then need 10 modules ?????




  • anirudh
    I see you've created a dateTest module, but this module has no dimensions. Can you also create a list with just one member, add that in Applies To for this module and then retry this action
  • No, as i have tried every mapping there is.. and none work, so don't know which one to share .


  • p7.JPGp8.JPG


    I have tried all combinations i think

  • p10.JPG

    I did already, it has a list called ListTest with 1 item '1' in it, and the failure was using this setup.


    This is so frustrating, I have built 10 models, over 100 modules and this is the simplest thing, and it just bugs me

  • anirudh

    Ok, now in your action, instead of mapping Column Headers to the listTest, make it fixed list member and in the listTest tab point the dropdown to the dummy member

  • Hi, yes already tried that, doesn't work


  • DeveloperCYT_0-1594894490162.png

    I do not have Colmun1: Dummy List as a mapping options?????


  • Finally,I understood. Thanks very much.
    Having a 'bad' day and nothing made sense.

    I now have the actions and can repeat with other saved views.

    The dates are going in to the 1 dimensional module and transferring out to where I need them.


    Thanks for your help. Much appreciated.