Load Data between two model from Numbered list to another Numbered list

Hi,

How can i automatically map my data load from data hub to FPA model?

 

In my data hub, i am using a numbered list(Coded) and trying to load this module in my FPA model using the same numbered list (Coded) but the mapping are not automatically updating.

 

> I have mapped the building Code-Dum to the coded building column.

tompatrickting_0-1596466891112.png

 

> The Building Code-Dum tab is not mapping automatically.

tompatrickting_1-1596466917030.png

 

> In my Building Code Dum, i have already set the code of the numbered list.

tompatrickting_2-1596467236521.png

 

 

Thanks in advance for the help.

Tom

 

Comments

  • hi @tompatrick.ting 

    Actually numbered list in Anaplan, even if codes are same in the source and target model, it doesnt mean that they point to the same item as numbered list item generated (#1 etc.) is unique for each Anaplan model, and different id is generated at the back for each model, so you need to actually map based on the name item # which will then look for the same # in the target model ,

    So try to use column 2 to map to dum code list num

  • @tompatrick.ting 

     

    Map on the code, not the # of Id nor the Name when using a numbered list.  The code is the only thing that will work across models.  The reason your import is not working is due to the 2nd picture, you should have codes in there instead of #1, #2, #3, etc.  So, check your view for the correct information.

     

    Rob

  • Hi @tompatrick.ting,

     

    We should use CODE only to import between 2 models, not NAME.

    You are mapping it correctly. I think initially you mapped it to the Column 2:Building Code Name, then later you mapped it to Column 4: Building Code, but the system is still referring Column 2:Building Code instead of column 4. 

     

    You can fix this in 2way,

    1. Simply delete the action and recreate it, 

    or

    2. Map Column Headers to the Building code-Dum and check the Building code-Dum tab, all the previous mapping are gone now. 

        Go to the Mapping tab and this time map it to the Column 4: Building code. Now check the Building code-Dum tab, this should work. 

     

    Regards,

    Vignesh M

  • Thanks all for responding.

     

    Hi @VIGNESH.M, i already tried both option 1 and 2 but still no luck. I also tried to delete the numbered list and re-create but still not mapping automatically if i use code.

     

    I cannot use directly the list name since i am synching 2 model and users can create or delete manually in the model that will cause miss alignment of the # list name.

     

    Is the only option i have here is to create a normal list?

     

    Thanks again for the help.

    Tom

     

  • @tompatrick.ting 

    In the target module, do you have a line item with the code of Building -Dum?  You will need this to map to which is why your 2nd picture isn’t mapping.

     

    Rob

     

     

  • @rob_marshall 

     

    Do i need to create a line item in my target module for the building code? I am already using the building code as applies to.

    tompatrickting_2-1596505181735.png

     

    Here is what i have in my mapping. It its showing the numbered list name not the code:

    tompatrickting_0-1596504945888.png

     

     

    Here is my numbered list Building Code-Dum

    tompatrickting_1-1596504997578.png

     

  • @tompatrick.ting 

    yes, you will need that in the target to map to.

     

    Rob

  • @rob_marshall 

     

    I tried to add a line item in the target module for building code but still doesn't map automatically in my building code mapping.

     

    Mapping in the line item:

    tompatrickting_1-1596508274569.png

     

    Mapping in the building code:

    tompatrickting_0-1596508246984.png

     

  • @tompatrick.ting 

     

    You need to use the code as the source as well.  In your picture, it looks like you are using the name or the member because it is the #number.

     

    Rob

  • @rob_marshall 

     

    I already mapped the building code in that screenshot.

     

    We are now thinking of creating a staging module in our FPA removing building code in the applies to and replace by #Numbered list then put the building code in the line item.

     

    I created a concatenate of GL Code and Building code to create the #Numbered list staging to store the data and will just link from the staging to the reporting module.

     

    Thanks for the support.

    Tom

  • Hi @tompatrick.ting,

     

    I am sorry. I know that i am late to this discussion but i replicated your scenario and it works well for me

    which means Numbered list codes in my data hub are automatically mapped to Numbered list Codes in my spoke model.

     

    I am not sure why are you facing this.

     

    But one question to you

    1. Have you first loaded the numbered list to your FPA model...?

    I think you might have forgotten to load numbered list.

     

    Before loading to the values or data to the module first you have to load the list.

     

     

    Thanks,

  • @tompatrick.ting 

     

    DM me when you get up and running and we can figure this out.

     

    Rob

  • Guys, thanks for helping. We decided to convert the list to a normal list instead of using a numbered list. We limited the character to 60 to avoid errors.

  • @tompatrick.ting 

     

    Booo!!!!!!  Offer still stands if you need it or want it.

     

    Rob