No access to a list in new UX

I can not choose from a drop-down list in a module (as the items are grey) in the new UX. But if I open the source module, I can work with it fine. So it seems that the access right to the module and the list is fine. Anybody knows why? Thank you!

Best Answer

  • xin
    Answer ✓

    I brought the issue to Anaplan Support and they helped me to fix the issue. However they still need to investigate what cause the issue.


    In my case, the list format underlying object value appears to be the root issue which causes the grey out selections in NUX list dropdown. To resolve the issue, go to the module/line item, reselect the line item format, go back to NUX, refresh the App and the grey out selections should disappear and you should be able to select the list items from the NUX list dropdown again.


  • Hi @xin 

    In the card Designer, do you have the allow editing toggle on? It would be my guess that you do not have this on if it works in the module, but not in the UX.





  • Hi! Yes allow editing is on. It worked before and I am not sure if I changed anything. Selective access is enabled for this list and I have assigned write access for all list members. It should apply to traditional dashboards and new UX in the same way right? I am really confused...

  • Hi @xin,


    I was facing the same. Seems some kinda bug.

    I republished the module, activated hierarchy filters  and allow editing.

    And Is working for me now.



  • Hi @abhi1017 

    Do you mean simply republish the module in new UX page? I tried but it does not work for me. 


  • @xin 


    Could you please share screenshot of the NUX page where the module is published and where you are facing the problem.



  • @xin 


    Is your query regarding editing the data in modules or Inability to select Context selectors/Dropdowns in NUX?. If it is former can you confirm if all of your context selectors are at the most granular level and if it is latter can you please post screenshot as it is worth taking a look



  • Hi @Misbah 


    It is regarding editing the data (choosing from a drop down list ) in a module, which is independent of the context selectors.

    As shown below, I cannot select from the list (the first pic) and I have turned allow editing on. But in traditional dashboard or the source module, it is working fine (the third pic). The list item selectable is even opposite.