One question regarding level 1 - Activity 7.2.3 : Import Data into Employee Details Module


Hello there, 


I meet one issue when I import data into employee details module for level 1, activity 7.2.3.


The result can be seen from screenshot (refer to Result.PNG). Here we can see that Name, Country, Start Date and Leave date columns were not imported at all. The imported report can be seen from screenshot (Import result.PNG). Have no clue why the start date and leave date were invalid data as import mapping were set up correctly (refer to Import mapping.PNG) as well as data format (refer to Blueprint view.PNG). 


Could you give me some guidance on how to solve this issue?


Many thanks in advance.

Best Answers

  • JaredDolich


    Oh, so close! So close!

    In your import results you got a message saying country and name were not mapped.

    Recheck you mapping and import again. Just make sure country and name are mapped. You got this!

  • keyyun627
    Answer ✓


    Hi Jared,


    Many thanks for the tips. It is solved now. 😉




  • @keyyun627 

    You're so so close. It's not that intuitive but you do need to map the dates to the right format.

    As for the country make sure there's not formula in the line item. Then you'll be able to map the CSV to the right line item in the Target module.


  • @JaredDolich 


    Hi Jared,


    Many thanks for your tips. The start date/Leave date work now after following your indication.


    However, Name column and Country column were still not updated after import (refer to Name and Country.PNG). The import completed report can be seen from screenshot Import Completed report.PNG.


    For Name column, what I found pretty wired is that E2 Employee mapping was not correct (refer to Employee name mapping.PNG). In fact, to avoid any duplication of number in the E2 Employee (number list), I also recreated the list E2 Employee in case but the result is the same. 


    For Country column, I ensured that there is no formula in the line item (refer to Country.PNG). 


    I am wondering if you have some idea what caused these errors? 


    Many thanks in advance. 

  • Having some serious difficulty 


    see attached for my import failure report



  •  Hi Team,


    I am facing issue in this activity , Can you please confirm my steps if I am going right for the mapping.

    Also for E2 emp mapping tab why its not mapping automatically ?

  • @abhinandan 

    Your .csv file has been modified. You'll need to re-download the employee.csv file so the employee codes have the preceding zeroes. For example, "009", not "9". Once you get the employee.csv file try importing the data again. I think you'll see it maps perfectly! You got this!