Unable to Import to the Same Module Using Saved View




I am having this difficulty since last night, I can't figure out how to address this issue. 

If anyone has encountered this issue before, what did you do to solve this? 




1. I have created saved views inside the same module. I'm using saved views to import to the very same module. 

2. The module has a custom version such as Budget Year and Forecast Year... and cuts such as Current cut and Previous Cut

3. The use of the saved views is to import the same information from Budget Year to Forecast Year , or from Current Cut to Previous Cut, into the same module

4. I have a specific line item in the module that I can't seem to import. It's the "Equipment Category" line item. It has a list Format and is a subset of another list, and it's a numbered List. 

5. Issue is, when I try to import the populated Equipment Category, an error would occur:

"Item not located in ss: MEQ Capex Element Leasing list: Air Compressor" --- but I know for sure that it's listed there. 


Screenshots attached. 


I'm trying to import the Equipment Category from Current Cut to Previous Cut for the same Budget Year:



In my mapping, I use connect to Anaplan model > Saved View and select that saved view I created. I'm only changing the custom version in the mapping because I want the information in the Current Cut to be imported to the Previous Cut: 



The line items are mapped correctly as well:


But when the import is ran, I'm getting the below error. Notice that it has 2 errors in it, and it looks like it does refer to the 2 populated equipment categories for "Air Compressor" above: 




Here's the subset and Air Compressor is really in it, what am I doing wrong? 😞 




Best Answers

  • jasonblinn
    Answer ✓

    Is MEQ Capex Element Leasing List a Numbered list? If so, you are trying to import the text/display name into a cell where it is looking for the #. You could stage this in a line item by using the NAME formula so that it shows something like '#1', or '#220' etc.


    Then you import from the name line into the line you enter it into and it should work.



  • jspascual
    Answer ✓

    Thank you, @jasonblinn  


    You directed me to the right path, I think it's now working...


    What I did:


    1. Created a staging line item as you have suggested, with the subset CAPEX Element Leasing as the Applies to. It created a subsidiary view and brought all the #s of the list members. But I only need those that are populated with the category.

    3. So I then created another line item and applied the same applies to above.

    4. I put a formula: Staging Line Item[LOOKUP: Equipment Category] and it then populate the original numbered list (#1, #2, and so on). This is the line item that I used to map in the import.  


    Thank you all!





  • Thanks, @jasonblinn . 


    Yes, it is a numbered list. 


    I think I have tried creating a line item -- though it is only a subsidiary view because I had to use the subset in the Applies To for this particular staging line item. I also tried putting a formula and it indeed brought in the #d items. However, it populated it for all of the members in the list. How can I import just those populated ones. In the module, not all equipment (in the row/left side) would be populated with equipment categories. In my example, only 2 equipment have the category, and I'm intending to import those just two populated with category into the same module but just a different Cut. 





  • Hey @jspascual 


    What is the Format of your line item "Equipment Category" ? Is it different from your subset ss: MEQ Capex Element Leasing list or your list MEQ Capex Element Leasing list ?