4.2 List Subset - Advanced Topics


I watched the '4.2 List Subset - Advanced Topics' video and am trying to apply what I see there.

There is a Boolean Line Item called 'Defined in Active Subset?' that is supposed to have a formula like this:


 But when I attempt to enter this formula I get this error:


I understand the error.  But it seems to say that the above, suggested formula, wouldn't ever be valid...


  • Hey Erik - If you change the formula to  be isnotblank(finditem('Defined in Active Subset?', code)) it will be able to do what you're looking for.


    The finditem is matching to a list(subset or not), so it is not finding the list in this case, rather you are telling it to search for the list then subset so formula doesn't work.  Does that help?

  • I can't use the name of a Line Item in it's own formula, right?
  • Sorry, read that wrong.  Reference the subset directly in the finditem item not the line item.  So formula would be: isnotblank(finditem('Active?', code)) 


    Also would recommend using a more descriptive SS such as SS active employee?  to be help differentiate.

  • My goal is to reference the subset directly. That is the problem. If I try clicking the subset it won't enter. If I try typing in the reference to the subset I get the error above.
  • The second approach is the correct one.  Rather than formula being: isnotblank(finditem('#e2 employees.active?', code)) it should be isnotblank(finditem('active', code)).  

  • That gives this error:



    Maybe I need to post more information.

    Here is the Employees List.  You can see the List Subset Boolean Column

    Employees List.png


    And here is the Blueprint for my Module:


     The goal is to get the Line Item called 'Defined in Active Subset?' to reflect the Booleans of the List Subset.

    The FINDITEM will be attempting to find an Employee, based on Code, in the List Subset.

    The ISNOTBLANK will set the Boolean to True if they are there.
    This all works if I use the Formula you can see in the screenshot.  But that gives me a TRUE for all Employees.  I need it to be True for just the Employees included in the Subset.

  • Ah I see it now.  There is an extra space in your original formula after the colon right? So should be:   isnotblank(finditem('#E2 employees: Active?', code))  instead of isnotblank(finditem('#E2 employees:Active?', code)) 

  • Thank you for your help!  That was way too hard to troubleshoot!


    The baffling thing was that I was unable to accomplish this formula using the "click to select" method.  Could I have done that this whole situation could have been avoided.

    To test it out I tried renaming the subset to just "Active."  Seeing if there were characters in the subset name that were stopping me from clicking on it.  Same result.  Clicking on the name of the subset (from this view) doesn't work for me when filling in a FINDITEM function:

    Employees List.png


    I can click on 'Display Name' and it goes into the formula.  But not on '#E2 Employees: Active?'



    Thanks, again, for helping me resolve this issue!  

  • Yeah you're right, there's no way to undock and click into list subsets but that would be nice.  Usually what I'll do is go directly to this list, double click into the subset line and copy it (being careful not to change the name), and then go to my formula line item and paste it directly in.  Less room for error.  Another recommendation I would make would be avoid special characters in the naming convention.  I usually try to stick to "SS Active Employees" or maybe "SS Active Employees?" just because this gives me less room for error (especially after a long day).


    Glad this helped resolve and apologies for the confusion on my responses, took me a bit to catch.   Have a good weekend!