Target mapping for imports into a model



I really do not understand target mapping when importing data for a model. Is there anyone who can help me with understanding this (may be with an example, since I am that much lost with this topic).


Thank you


  • Hi @nimesha ,


    The easiest, and best practice, is to have codes everywhere.


    Once you link the column to the list the mapping should be there automatically.

    If that's not possible you could always open the tab of the specific list and switch to manual mapping. There you can link the elements as you wish.


    There is a bit more meat around this topic here.


    All the best,



  • Hi MaartenGijbels 


    Many thanks for the reply.


    I do not get any automatic mapping and whatever the mapping I do get unsuccessful. Even the link that you say does not exactly say how to do this mapping thing properly. Please help.




  • Actually it seems like I get only some of the data and I get below error message. I guess I am not selecting correct source for the target. Could you please tell me how to find out, what should select in the source tabs.


    Thanks a lot


    Screen Shot 2020-08-31 at 8.11.29 pm.pngScreen Shot 2020-08-31 at 8.12.46 pm.png

  • Hi @nimesha ,

    In Module Import Process Source and Target Names(line items) will auto match if they  visually  same ,incase if auto match not happened than we always have an option of manual mapping . 


    From your Screenshot "line item identifier errors " normally cause if the respective line item is not mapped ( left blank) or if the format of that respective line item is in different format ( source : text but formatted as number).


    To avoid this we can edit the respective action and check the mappings of respective line items ( source vs Target).






  • It's a bit of a pain,


    But could you add a screenshot of your source and every tab within the import process? That will probably clarify a lot.


    You could prepare by paying specific attention to tabs that are suspiciously empty.



  • Hi, 


    Yeah it is a pain as I have wasted good 5 to 6 hours only on this importing data thing. I even deleted whole employee details module and created freshly. Tried to manual map, but still did not work. I have attached step wise screenshots of what I have done. Can someone please tell what I am doing wrong.



    NimeshaScreen Shot 2020-09-01 at 4.21.48 pm.pngScreen Shot 2020-09-01 at 4.22.09 pm.pngScreen Shot 2020-09-01 at 4.22.21 pm.pngScreen Shot 2020-09-01 at 4.22.34 pm.png

  • Hi @nimesha ,


    On the screen of your 2nd and 3rd step you see additional tabs. (1 for the employee list and 1 for the line items.)


    Could you open these? This is were the mapping comes into play.


    Do the employees in your first column automatically map with the employees in your list?

    Do the column headers link to the line items?


    All the best,

  • Hi Maarten,


    Attached are those screenshots that you asked for. No, 1st column comes empty. I am the one who selected employees in that.


    Really appreciate your support.

    NimeshaScreen Shot 2020-09-01 at 5.42.37 pm.pngScreen Shot 2020-09-01 at 5.42.51 pm.pngScreen Shot 2020-09-01 at 5.42.58 pm.png

  • Hi @nimesha ,


    From your Screenshots what i understood is "Start Date & End Date" line items failing with errors , can you check the formats in source file and line items formats in module .

    In your 3rd Step we can check whether Source file Date records are matching or not & also we also have multiple date formats. ( Pls check attached screenshots ) 





  • Hi Kuruva,

    I did try to change date format and do as you said, but it did not work too. 

    I have formatted start and end dates as "dates" in formatting. As per my understanding Anaplan use our computer system date format. In my computer it is DDMMYYYY. Could you please advise me, in this case which should I select in the attached dialogue box.


    Thanks a lot

    NimeshaScreen Shot 2020-09-01 at 5.58.03 pm.png

  • Or could it be that I have done something wrong in the earlier steps which affect data importing part. In that case should I start everything from 1st?



  • Hi @nimesha 

    Can you try Fixed Position Patterns like i tried in below screenshot .date3.PNG



  • Hi Kuruva,


    Still same. I have attached the error message. Could you please tell me what have you selected in source columns. I have selected employees and column headers. May be something wrong there.



    NimeshaScreen Shot 2020-09-01 at 6.13.49 pm.pngScreen Shot 2020-09-01 at 6.14.19 pm.pngScreen Shot 2020-09-01 at 6.14.31 pm.png

  • Hi Guys,


    This issue has been solved as I follows the instructions which was in another question link. Seems like I have been selecting 1st column incorrectly, which should be code.


    Thanks a lot for all your support.