Synced page selector not loading correctly in line chart


I have a classic dashboard built to display KPI data with two line charts, both based off of the same module dimensioned by month, KPI metric, and Project.  Most of the projects don't yet have KPI data entered, so the data is heavily filtered to check for non-zero budgeted values.


Both graphs have time on the x axis. One shows a single metric for all projects and the other shows one all metrics for a single project.  The former displays just fine, but the latter gives an invalid selection for chart error with a page selector error displayed of the ! in the yellow triangle followed by "[Project]: No items".  The intent is to have the project page selector where the error is present synced to the grid display above.  Note that the chart in error with the project dimension page selector uses the same dimension as the series (row) dimension, which displays perfectly, as it does in the grid for syncing.


We are using ALM, and this function works just fine in the dev environment that syncs to the deployed model where the error manifests.  The chart defaults to a project that has no data (so the No items error doesn't appear), but selecting a project in the grid for syncing leads to the expected chart displaying as expected.  I wouldn't mind if the chart didn't appear correctly on initial load if clicking on a project resolved the error as happens in dev, but the syncing is unresponsive.


Is this a known limitation?  Please advise. 



  • @chrised209 


    Do you have any filter applied to the projects list? 

    Synchronisation will not be enabled if you do! 

    From the error message and the statement that confirms the charts are heavily filtered I suspect this is the case.

    Try disabling all the filters and testing again.

  • I do, in fact, have a filter on the project axis.  However, I have the same filter on the KPI metric axis in the other graph and it nevertheless handles beautifully, and it is no problem in the dev environment.  Would that the errors manifested consistently!


    I'll **** the filters, regardless.  Instead I'll see about building a subset to identify where KPI data is present and use that to re-dimension the module.  It should save me quite a bit of space, anyway.


    I'll have to wait until Friday to push an update, but I'll report back then to update on how the production model takes it.

  • Clearing the filter on the Project axis did the trick. I was able to push to prod this morning and got the desired result.

    Thank you!