Import Data into Product Details Module



I'm struggling with the 7.2.1 Activity: Import Data into Product Details Module.


I have attached the screen shot. Can I please get some help on this.








Best Answer


  • Thanks Puneeth. It worked.

  • I'm still having issues with it. How do I add Size?




  • Hi @LRanaplan 


    The size detials are available in the file, so you need to the appropriate mapping with Size coloumn of the file and the size line item in the module.


    Check your action mapping once and see that is as per @Puneeth H P  screenshots.

  • Having same issue as well. What am I doing wrong with the way I set up module SYS06



  • @JosephA i see you have places the products in pages so you are seeing only one product. Go to the pivot option and keep the products in rows and line items in columns so that you can view all the data.




  • this is the error report I'm getting once I do that


  • @JosephA looks you are mapping size to product list in import action mapping. 

    You need to map product code column with product list and size in line item(by selecting fixed line item).

  • I did switch and here is what I get, I'm missing the code and product family code

    no code.png

  • not sure if my set up is completely wrong. SOS please 🙂

  • Product Code and Product Family details needs to populated using formula.
    Product code = Code(Item(Product list)) and Product Family = Parent(Item(Product List))

  • awesome!!. Thank you. After the formula, this is what I got. Do I still need to worry about Product family code ?



  • Not required. Looks good

  • Thank you very much!!. now I can go to bed 🙂

  • I'm having the same issue with 7.2.4, I did the formula this time for code and department, but for the code, it returned a name and not a code after I imported, and then country, start date and leave date, not sure if that is a formula as well. Any thoughts on what my mistake is?


    Employees SYS08.png

  • I think my mistake is here, but I've tried correcting and to no avail. This is not as straightforward as I thought. I wonder how many customers get frustrated 🙂



  • Hi Guys, 


    When I import the data I do not get the same thing as you guys and I dont understand why. 

    Capture d’écran 2021-01-06 à 15.19.35.png

  • Hello,

    Instructions are missing here. It should have clearly specified that we are populating the Size. The other 2 fields will come as a formula in next task. I spend 45 mins on this until I found this forum. 

  • Hi @Puneeth H P I am facing issue related to this 7.2.1 Activity: Import Data into Product Details Module.


    I want to understand how can I remove Time dimension from the module ?


    Also I have followed steps mentioned by you for the mapping but for rows are getting ignored  and I am getting drop down list for the size column to fill the data. Can you please help .

  • Hello Abhinandan,


    Time dimension can be removed by going to blueprint mode and removing from there.

  • Okay thanks for your help. Its done
  • Hi, 

    Im struggling with the mapping of "7.2.1 Activity: Import Data into Product Details Module". 


    Im getting the error below


    Below what I am choosing for "source".



    Can anybody help?


    Thank you