Level 1 - Lesson 7 - SYS08 Importing Employee Details Module


I had to run separate imports. One for Name, StartDate, LeaveDate, Current Salary and Commission and another for Country since Employee.csv file has Country Code column and hence was not able to map on to Country Name.

Is there a formula that would take Country Code during import and list appropriate Country Name ?


  • GONI

    Hi, There is no need to run import twice. While importing first time select appropriate mapping from Source to Target. Attached screen capture for reference.


    Stay Safe.


  • My country code is greyed out so I don’t have the option to map it to country



    I mapped correctly and imported the data, but I failed to import the Start Date and Leave Date. It says invalid date. I tried a few times, but I still cannot fix it. Can anybody help me? 





  • You have to Select the correct format for Start and End dates. Click Edit from the custom mapping section of Line Items Tab. This will open another PopUp for Mapping the input Date format to output date format. I've attached a screenshot


    I got it! Thank you for helping!

  • I'm also having a hard time with this one.

    1) We're supposed to move the TIME out of the original model when we first move it in, right?

    2) I notice that when I do it with the TIME dimension, it allows me to choose the formatting (YYYYMMDD) but when I omit it entirely, I do not see anywhere to select a format.

  • I have an odd thing happening.  When I import the data, it shows it imported successful, but no data is showing up in the SYS08 Module. Here is the message I'm seeing after running the import:


    Screenshot 2020-11-05 at 16.15.18.png

     So my Module then shows as empty.  It didn't do this previously when I imported SYS06 Product Details Module.  Help anyone?

  • Nevermind, I had to run separate updates for each column. Thanks for the tip @tanmaygupta
  • This usually happens if you don't map the columns in your sheet to the one's defined in the module correctly or if the system is'nt able to identify it while importing. Running separate imports like you did should work.
  • I also am having trouble here - @CrystalZ_old1 did you end up removing TIME out of the model? 

  • I removed it, but then I saw no way to set the date format for it. Then I changed the format to number just to import it in, and then I tried to change it to date afterwards but it does not convert the way that I want it to.
    I am embarrassed to admit this, but I wanted to move forward since in a later module you need to be able to reference these dates again and I was getting so frustrated with it, so I just pulled up the Excel side by side, organized it with a few filters, and then manually entered the numbers in for now. It only took about five minutes. I know it's not the right way, but I didn't want to be stuck forever.
  • I appreciate the honesty, I am also getting very frustrated and want to move on. Thanks so much for the "shortcut". 

  • Hi Crystal, 


    Can you send me your model name? I will take a look for you. 




  • Hello, 


    Can you send me the name of your model and I will take a look? 

    Thanks Marie

  • Its listed as my name MariePapa

    I tried importing again and get a totally different screen. 


    Thanks for the assistance,






  • Hi Marie, 


    In Modules, you need to import from Grid View. 


    That is why you are getting a different view. 




  • @Pianojac25 or @GONI By any chance can you see what I might have done wrong? I don't think this is correct. And when I change around the employee and code, I get an error on the import.

    I changed the dates as mentioned earlier in the feed - please see attached files.


    Thanks for any insight,


  • It worked after I added the formulas! thanks!
  • I added the formula and it worked! Disregard my message 🙂 Thanks!