Error: Dimension of mapping used for lookup doesn't match any dimension of the result


Hi gurus, 


When building the reporting module 'REP04'(the target) I've tried to reference an existing module 'EMP03' (the source) for the calculated medical costs. REP04 has two dimensions 'Region' and 'Role' whilst EMP03 has 'Department' and 'Role', hence I tried the mapping module 'SYS08' to fill the gap. Thought it's ok but still run into 'Dimension of mapping used for lookup doesn't match any dimension of the result', any help is much appreciated. 





Best Answer

  • JoanneM
    Answer ✓

    @einas.ibrahim No worries, I figured it out I've got EMP02 calculated at good granular level so I just need to sum them up together by two dimensions in my target module. 


    Problem is solved. 🙂 


  • Hello @JoanneM 


    You are on the right track.
    Check this post, it might help you understand the root issue and arrive at the solution yourself 😊



    If you still have questions please let me know.


    Good Luck

  • Hi Einas, 

    Many thanks for your swift reply, I saw the quoted post and it was helpful. 

    I've given it another shot but this time it throws an error: Format of mapping used for lookup doesn't match any dimension of the source. 

    This is the thread of my thoughts: 

    1. My target module REP04 has region and role as two dimensions.
    2. I've referenced a different source this time the EMP01 which uses G2 Country and Department as dimensions, it also has medical costs data.
    3. I've also had another module EP03 Employee Drivers by Role which is dimensioned by Department and Role, as part of the example data was imported via csv file. 
    4. So technically what I'm trying to do is to join EMP01 with EP03 on department, based on the result set to aggregate them into region vs. role so to populate my target module REP04. 

    Not sure whether I'm still on the right track? 








  • Hello i'm stuck in the same level would u like to share the Formula 



    Thanks in advance

  • Same for me, I have split it as well by two dimension but still shows the same error. 

    Thanks very much in advance