Cloudworks Seetup Issue


My ability to login to AWS and reach bucket is validated and all is good on the AWS side


Setting up the Cloudworks Connection seems to work and getting a valid connection.


When an Integration is being setup, I can connect to model and see what I would like to export from Anaplan, but the Data Target remains greyed out and the error: 

Failed to load files from Amazon S3


pops up.


Our AWS administrator can see that there is nothing beyond the connection.


I am set with integration role...and have tried it by loggin in with our service account with full access that is used for all our Anaplan Connect API integrations...this role is also set as Integration role.


Any ideas on what might be preventing getting the integration part setup with Cloudworks?




  • @ben_speight  Don't know if anybody else can help @stephen.hoffer hence looping you.

  • I don't really know this area but will ask around...

  • @stephen.hoffer Can you check whether you have write permissions on S3? You can just try copying into S3.

  • Hi Stephen, I have experienced something similar before.  Try this: attempt to create the integration on the "Create new integration" screen as you did for.  Check if the data source (your bucket) is available for selection.  If it is greyed out (as you were seeing before) then cancel out and then try to create a new integration again following the same steps.  I was noticing that it would only recognize the bucket the second time around.   

  • Yes...I have write permissions The AWS admin validated this.

  • I just tried that too.


    I am thinking that using Anaplan Connect on AWS will work better and there is a history of folks having success going that route.


    It is not worth being the tip of the spear on this one. If it is not easy to use and figure out, it quickly become a blocker.


    Thank you everyone for trying to help.

  • It looks like access issues to the files in the AWS bucket.
    I would highly encourage to look at the bucket permissions section at:

    Also has your AWS administrator setup any IAM roles or is it straight up service account for accessing AWS S3 bucket?

  • DibB
    Users can setup integrations with Amazon S3 bucket that has fewer than 250,000 files (including folders and sub-folders). If your bucket exceeds this limit, then the workaround is to either setup a new bucket for the "planning" files or reduce the number of files in the original bucket. 
    If the above workaround does not work for you, can you please create an Anaplan Support ticket so that we can address the root cause of the issue?
  • @stephen.hoffer 

    Some ideas:

    • Name files with .csv  Example: Data.csv.csv
    • Export and Import file names have to be different
    • 25 integration limit then pay as you go
    • No processes can be run, only actions
    • cannot do model to model yet
    • Integrations can be scheduled but once scheduled you cannot run it manually

    Also, this was just released today:


  • No IAM straight up access

  • The files in the bucket are nowhere near the limit mentioned and there is a ticket already submitted.