Anaplan connect via JDBC with SQL DB (partial data loading)



We are using Anaplan Connect 1.4 to load data into SQL database via JDBC conneciton. the export script when manually exports 2459 but when the export is triggered through Anaplan connect only partial data is getting loaded. Can someone suggest me what is going wrong here?



2021-01-26 13:06:16 INFO 216 |-- serverAlert - Completed successfully!
2021-01-26 13:06:16 INFO 216 |-- exportName - New EU Export
2021-01-26 13:06:20 INFO 216 |-- Export New EU Export to database started successfully
2021-01-26 13:06:20 INFO 216 |-- Created JDBC connection to: jdbc:sqlserver://.......;authenticationScheme=nativeAuthentication;xopenStates=false;sendTimeAsDatetime=true;trustServerCertificate=false;sendStringParametersAsUnicode=true;selectMethod=direct;responseBuffering=adaptive;packetSize=8000;multiSubnetFailover=false;loginTimeout=15;lockTimeout=-1;lastUpdateCount=true;encrypt=false;disableStatementPooling=true;databaseName=.......;applicationName=Microsoft JDBC Driver for SQL Server;applicationIntent=readwrite;
2021-01-26 13:06:20 INFO 216 |-- Writing batch 1 (1000 records)
2021-01-26 13:06:20 INFO 216 |-- Batch 1 written (0 records committed,0 records errored out)
2021-01-26 13:06:20 INFO 216 |-- Writing batch 2 (1000 records)
2021-01-26 13:06:21 INFO 216 |-- Batch 2 written (1000 records committed,0 records errored out)
2021-01-26 13:06:21 INFO 216 |-- Writing batch 3 (459 records)
2021-01-26 13:06:21 INFO 216 |-- Batch 3 written (0 records committed,0 records errored out)
2021-01-26 13:06:21 INFO 216 |-- Transferred 1000 records to jdbc:sqlserver:





  • Is this consistent every time?
    Also, it has been a month since this post, did you resolve it?

    In the JDBC connection string you could try packetSize -1 (but not sure this would affect anything here).

  • Hi Siva,


    This is an interesting issue you have brought up. Last year when I used to work in Support I recall seeing a similar case, though I don’t recall the solution. Can you try emailing They will have access to the previous cases and may have similar reports that could help solve your issue of partial data loads

  • One the same topic. We are in the process of automating our data feed in Anaplan. We are using Java. 

    We have attempted to load 538 pretty small files today, and in Anaplan model, we discovered that only partial data for some months and days has loaded successfully. 


    We then tried to reduce then number of files loaded to only 3.The very first file has failed to load the data Although the Unique Reference which we set up in house did show in the list and in the model, however under those Unique Refs no line items got populated. The other 2 files loaded with no problem with data appearing in the Upload model.  Process in Anaplan has been checked multiple times including the format of line items, and the mapping in the import process. 

    No issues found there. I then tried to upload the missing file manually in to Anaplan. Again, data has come through with no issues or errors. 


    It would appear when loading multiple files via Java the lot of data populates the Unique Ref in the List , and shows in the model but the actual data behind it is no where to be found, both myself and our BI team incl Java Developer are baffled by this. 

    Would you be able to suggest anything pls?