Run a Process via Informatica (Delete and Insert)


I tried to "run" a process.  Process runs when manually clicked in Anaplan.

Process has two actions

     Delete table contents

     Import data from Data Hub


I tried to set as

    Source : Dummy table from SQL Query (1 Column 1 row : Set = 1)

    Target  : Desired Process 

                   (Tried Operation = Insert and Update  both failed)


Does not seem to initiate Process. Is there a special way to map the fields?  Or has anyone been successful in running processes? 

Best Answer

  • JaredDolich


    Great question. As @rob_marshall mentioned in an earlier post you can certainly run a process from Informatica.

    I'm wondering if this might be your issue: make sure that when you create the import action (or export action) that you save the action as "EVERYONE". If you don't, Anaplan won't find the file.

    See if that helps.

    One last observation. Delete and Insert is a very heavy processing solution because the delete action will turn on the logging. Highly recommend you UPSERT if you can. Use audting modules to weed out the records you no longer need. Your processing will be much faster.

    Hope this helps.


  • Thank you @JaredDolich 


    In addition to Jared's response.  I simply had to manually alter data in the module I was updating so I could see that in face the process ran successfully.


    I have a timestamp column but this was reflective of the time data came into the Data Hub not the time I executed my process so it tricked me to think my process was not running when in fact it was.


    **Oh all those times I joked about others making sure things are turned on or plugged in**