Level 1 Model Building SYS08 Employee Details Import Issue

Contributor

Level 1 Model Building SYS08 Employee Details Import Issue

 

We are asked to import Emloyees.csv into SYS08 Employee Details and I am unable to get the names in the list to match on the names in the employees list that I already have in. I checked and I have the data type as "Text" listed within the SYS08 module, and the .csv has the data in that column listed as "General". I also tried changing that to "Text"; neither work. I can do it manually but it will take a long time.

 

Is there something I'm missing or should consider?

 

 

 

Import Problem.PNG

7 REPLIES 7
Super Contributor

Re: Level 1 Model Building SYS08 Employee Details Import Issue

Hi,

 

in the first tab, Mapping, which field are you using to map the Employee ? You should be using the code, not the name.

Nathan Rudman
Anaplan Model Builder
Message 2 of 8
Contributor

Re: Level 1 Model Building SYS08 Employee Details Import Issue

Thanks for the response. Here are some more screenshots:

 

This first one shows the mapping that corresponds to the screenshot from the original post.

mapping1.PNG

 

 

This second one, I believe, follows how you are implying I should be mapping.

 

Mapping2.PNGThis third one shows what I see when I use the Mapping set up from the second screenshot. It still doesn't seem to be working. 

 

Mapping3.PNG

 

What am I missing? Thanks in advance!

Message 3 of 8
Certified Master Anaplanner

Re: Level 1 Model Building SYS08 Employee Details Import Issue

Hi,

 

#E2 Employee is a number list, so we can't use the name for mapping. We should use code for the import.

 

Your mappings are right, please download the file again and try to load it.

 

Regards,

Vignesh M 

Message 4 of 8
Super Contributor

Re: Level 1 Model Building SYS08 Employee Details Import Issue

your mapping is correct here.
The reason why it is not working is probably because your employee list doesn't have the code set up (you might have missed it when creating it). Re import the employee list with the code and it will work
Nathan Rudman
Anaplan Model Builder
Message 5 of 8
Contributor

Re: Level 1 Model Building SYS08 Employee Details Import Issue

Here is a screenshot of my employee list, where you can see that each employee does have a code associated with them. Do you recommend that I clear out this list and attempt to repopulate it?

 

EmployeeList.PNG

Message 6 of 8
Super Contributor

Re: Level 1 Model Building SYS08 Employee Details Import Issue

no that's the right code.
But you can see in the data you have, the code is not 001 but 1, so Anaplan cannot match it.
That usually happens when you open the CSV file with excel and save it, then import the saved CSV. Re-download the CSV from the training and reload that file, without opening/saving in Excel
Nathan Rudman
Anaplan Model Builder
Message 7 of 8
Highlighted
Contributor

Re: Level 1 Model Building SYS08 Employee Details Import Issue

That appears to have done the trick - good catch. Here is a screenshot of what it looks like now that it has successfully uploaded and matched the codes:Solution.PNG

Message 8 of 8