Contributor

Level 2 Model Building: SYS08 Incorrect Data Population

I encountered an issue with my SYS08 module in which the data isn't being reflected the way it should. Products are not correctly population under their parent, instead they are put in at the bottom as shown in this screenshot:

 

incorrect population.PNG

 

This leaves the "parents" blank:

 

Blank.PNG

 

I have tried rerunning processes 1 and 2 (responsible for building and populating hierarchies), and it hasn't fixed the issue. Any ideas?

 

Furthermore, if you look at the first screenshot, Nutzo Bar_EN says it is supplied by "New York". This seems wrong. Perhaps this will be resolved once the data is correctly in the module.

10 REPLIES 10
Community Boss

Re: Level 2 Model Building: SYS08 Incorrect Data Population

@RobinSilk ,

 

What does the action look like where you are pulling the data from?  What does the view look like from the data hub?

 

Thanks,

 

Rob 

Contributor

Re: Level 2 Model Building: SYS08 Incorrect Data Population

Thanks for the response. Here is what the view looks like from the Data Hub:

 

Import View.PNG

Highlighted
Community Boss

Re: Level 2 Model Building: SYS08 Incorrect Data Population

@RobinSilk ,

 

And the Action?

 

Rob

Contributor

Re: Level 2 Model Building: SYS08 Incorrect Data Population

I'm not sure what the best way to show the action is that gives the most insight into it. Here I highlight the source label:Action.PNG

 

Here are all the relevant imports:

 

Relevant Imports.PNG

Community Boss

Re: Level 2 Model Building: SYS08 Incorrect Data Population

@RobinSilk ,

 

No, the actual mapping within the action.

Contributor

Re: Level 2 Model Building: SYS08 Incorrect Data Population

Mapping1.PNG

Super Contributor

Re: Level 2 Model Building: SYS08 Incorrect Data Population

not this action. The import is two action: 1 create the list, 2 import the data. You need to open the action 1.5 and change the parent mapping in there, rerun it
Nathan Rudman
Anaplan Model Builder
Contributor

Re: Level 2 Model Building: SYS08 Incorrect Data Population

Okay, should I be setting SKU Flat as the parent here?

 

1.5.PNG

Super Contributor

Re: Level 2 Model Building: SYS08 Incorrect Data Population

no. Where are the SKU located ? that will be the parent
Nathan Rudman
Anaplan Model Builder