Number format being changed when importing between models

Contributor

Number format being changed when importing between models

I am attempting to set up an import between modules in two models; the target module has a has a list of numbers as the 'applies to' while the souces has a list of business areas.

To get around this I have created a line item in the source module to assign each entry a number reference.

This number is formatted at zero decimale points, so it matches he list in the target model.

The issue is, when I try and import it is stating that the number from the source module is to 1 decimal point, and as such it won't match the target - see attached image.

I'm sure there's probably something obvious I'm missing and any advice would be appriciated 

4 REPLIES 4
Super Contributor

Re: Number format being changed when importing between models

Hi Ceri

 

Line item 1: 1.0, Number Format

Line item 2: 1, Text Format, Formula: Text(Line item 1) and use Line Item 2 for the imports.

 

Hope this helps

Message 2 of 5
Highlighted
Contributor

Re: Number format being changed when importing between models

The work around did the job, thanks - though slightly annoying that it happens in the first place, not particularly conducive to model efficiency.
Message 3 of 5
Super Contributor

Re: Number format being changed when importing between models

Hi Ceri

 

If you are not using the number formatted line item for anything else, then you can directly format that line item to text and load the numbers or submit the numbers there.

 

I know its bit of pain but this is the work around we could come out with.

Message 4 of 5
Community Boss

Re: Number format being changed when importing between models

@Ceri

@harish_bk

 

Cheat tip!!

Set the code of the ID list to 1.0, 2.0, 3.0 etc

This will then match automatically2018-11-23_13-26-17.png

 

2018-11-23_13-25-49.png

 

You can always reference the NAME in formulas if you are needing the 1,2,3 reference

Hope this helps

David 

 

 

Message 5 of 5