Can't get my export right

LouiseBourgonjon
Contributor

Can't get my export right

Hi community members,

 

I have created a saved view in which I enable a filter to filter out any rows which have a CIP value  (kLOC) = 0.

The filter uses a boolean line item in the module itself, which defines if the value is different than 0.

When I look at my saved view, it looks good.

However, when I export the view, the rows with CIP value (kLOC) = 0 are still included in the export.

I don't understand why. I have first created the saved view and then ran the export action.

Can anyone help? 

Another strange thing: when I open the filters of my saved view, a number of filters seems to be added automatically, without me selecting it. Maybe this is messing it up? But how do I get rid of this automatic additions?

I have attached some print screens to make it more clear.

 

Thank you for your help!

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
LouiseBourgonjon
Contributor

I checked this with Anaplan support and they came back to me with the following answer:

 

After further investigation by our Product team, it has now been decided that we currently do not plan to fix this issue. 
The workaround for this issue is to remove the existing filters, export data the way you normally do and then apply the filter in Excel. This issue has also been documented on the Known Issues page on Community and can be found here .

View solution in original post

7 REPLIES 7
Misbah
Moderator

@LouiseBourgonjon 

 

Are you using Tabular Multiple Column option while exporting it out. If yes, then saved view filters are not supported. 

Try using Tabular Single Column option

 

Misbah

LouiseBourgonjon
Contributor

Hi @Misbah ,

 

I am actually using the Grid layout, because I want a separate tab for each page selector item.

Misbah
Moderator

@LouiseBourgonjon 

 

In that case you will have to check if the export action has been created by using the saved view. I doubt it.

 

It must be using some other saved view or the default view. Go to Saved View, Run Export and see if it throws similar results

 

Misbah

LouiseBourgonjon
Contributor

Hi Misbah,

 

That is what I did.

I delete any other existing export action on that module, I go to the save view and I click data, export and I save the export action.

Misbah
Moderator

@LouiseBourgonjon 

 

Strange!

 

Raise a ticket with Anaplan Support

LouiseBourgonjon
Contributor

@Misbah , I raised a ticket. I will keep you posted on the outcome.

LouiseBourgonjon
Contributor

I checked this with Anaplan support and they came back to me with the following answer:

 

After further investigation by our Product team, it has now been decided that we currently do not plan to fix this issue. 
The workaround for this issue is to remove the existing filters, export data the way you normally do and then apply the filter in Excel. This issue has also been documented on the Known Issues page on Community and can be found here .